summaryrefslogtreecommitdiff
path: root/gnu/packages/debug.scm
diff options
context:
space:
mode:
authorMarius Bakke <[email protected]>2020-11-15 23:45:34 +0100
committerMarius Bakke <[email protected]>2020-11-15 23:45:34 +0100
commit4e5e05d40908e9f1336ffc5a6c4928ab61ad034c (patch)
treead6d6be0ece396ba3353871a5691e514253508f8 /gnu/packages/debug.scm
parent2c400ae94207b3b84fcdcaa21c122076c050d307 (diff)
parente1fa3ea9fe8d01dd124c5e304bde9243876378ba (diff)
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/debug.scm')
-rw-r--r--gnu/packages/debug.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/debug.scm b/gnu/packages/debug.scm
index 9dc32c70f4..b3a000e6e3 100644
--- a/gnu/packages/debug.scm
+++ b/gnu/packages/debug.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014, 2015, 2016, 2017, 2019, 2020 Eric Bavier <[email protected]>
;;; Copyright © 2016, 2017, 2018, 2020 Efraim Flashner <[email protected]>
-;;; Copyright © 2018 Tobias Geerinckx-Rice <[email protected]>
+;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice <[email protected]>
;;; Copyright © 2018, 2019 Rutger Helling <[email protected]>
;;; Copyright © 2019 Pkill -9 <[email protected]>
;;; Copyright © 2020 Vincent Legoll <[email protected]>
@@ -566,7 +566,7 @@ error reporting, better tracing, profiling, and a debugger.")
(define-public rr
(package
(name "rr")
- (version "5.3.0")
+ (version "5.4.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -574,18 +574,19 @@ error reporting, better tracing, profiling, and a debugger.")
(commit version)))
(sha256
(base32
- "1x6l1xsdksnhz9v50p4r7hhmr077cq20kaywqy1jzdklvkjqzf64"))
+ "1sfldgkkmsdyaqa28i5agcykc63gwm3zjihd64g86i852w8al2w6"))
(file-name (git-file-name name version))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags
;; The 'rr_exec_stub' is a static binary, which leads CMake to fail
- ;; with:
- ;;
- ;; file RPATH_CHANGE could not write new RPATH:
- ;;
+ ;; with ‘file RPATH_CHANGE could not write new RPATH: ...’.
;; Clear CMAKE_INSTALL_RPATH to avoid that problem.
(list "-DCMAKE_INSTALL_RPATH="
+ ;; Satisfy the ‘validate-runpath’ phase. This isn't a direct
+ ;; consequence of clearing CMAKE_INSTALL_RPATH.
+ (string-append "-DCMAKE_EXE_LINKER_FLAGS=-Wl,-rpath="
+ (assoc-ref %build-inputs "capnproto") "/lib")
,@(if (and (not (%current-target-system))
(member (%current-system)
'("x86_64-linux" "aarch64-linux")))
@@ -613,7 +614,7 @@ error reporting, better tracing, profiling, and a debugger.")
("which" ,which)))
(inputs
`(("gdb" ,gdb)
- ("cpanproto" ,capnproto)
+ ("capnproto" ,capnproto)
("python" ,python)
("python-pexpect" ,python-pexpect)))
(home-page "https://rr-project.org/")