summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2024-09-01 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2024-09-08 02:00:00 +0200
commit49cd866090e1ad3f80fa450467329f3782ca09e5 (patch)
tree204f6ad834a5ce00d698e5b27df6ce6a6aaf0661 /gnu/packages/crates-io.scm
parentff5d9ae0fa76fa7bf8e4424ab8ff01e13bd906a4 (diff)
gnu: bcachefs-tools: Update to 1.11.0.
* gnu/packages/crates-io.scm (rust-rustix-for-bcachefs-tools): New public variable. * gnu/packages/file-systems.scm (bcachefs-tools-rust-target) (bcachefs-tools-target/release, bcachefs-tools-cargo-args) (bcachefs-tools-make-flags, bcachefs-tools-make-install-flags): New variables. (bcachefs-tools): Update to 1.11.0. [build-system]: Switch to Cargo. [arguments]: Remove #:make-flags. Add Cargo keywords. Run the test suite with upstream defaults. Delete 'promote-mount.bcachefs.sh phase. [native-inputs]: Remove python, python-docutils, python-pytest, and valgrind. [inputs]: Remove bash-minimal, coreutils-minimal, gawk, and util-linux. Add clang. (bcachefs-tools/static): Modify #:phases instead of #:make-flags, and adjust accordingly. Change-Id: I872f5dea88b75f855f3cdcbffbbd9c70d7ebe8d6
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm16
1 files changed, 15 insertions, 1 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 0cdb071ea0..c08ccd29fd 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -66141,7 +66141,7 @@ rustc compiler.")
(define-public rust-rustix-0.38
(package
(name "rust-rustix")
- (version "0.38.31")
+ (version "0.38.31") ;XXX drop rust-rustix-for-bcachefs-tools when updating
(source
(origin
(method url-fetch)
@@ -66195,6 +66195,20 @@ rustc compiler.")
;; Apache 2.0, Apache 2.0 with LLVM exception, or Expat.
(license (list license:asl2.0 license:expat))))
+(define-public rust-rustix-for-bcachefs-tools
+ ;; The package above is too old; too many dependents to update it directly.
+ (package
+ (inherit rust-rustix-0.38)
+ (name (package-name rust-rustix-0.38))
+ (version "0.38.34")
+ (source
+ (origin
+ (inherit (package-source rust-rustix-0.38))
+ (uri (crate-uri "rustix" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "03vkqa2ism7q56rkifyy8mns0wwqrk70f4i4fd53r97p8b05xp3h"))))))
+
(define-public rust-rustix-0.37
(package
(inherit rust-rustix-0.38)