summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2025-01-23 15:38:21 +0100
committerRicardo Wurmus <[email protected]>2025-01-23 15:59:20 +0100
commit08f18a48e3a01e8add4a02f9ed6681fefc68a825 (patch)
treebd0c1b017fb7daaa69dbbd46b73ada533f097bf1 /gnu/packages/cran.scm
parentb334549d49deedf56d5a537e701ff1a3ce182194 (diff)
gnu: Add r-spdl.
* gnu/packages/cran.scm (r-spdl): New variable. Change-Id: I4a900bb33cf5a7a04a1f71eac4283e6a813e3e59
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index efbc1c6c24..3983948b17 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -7764,6 +7764,30 @@ page dashboard or a multi-page template, where the navigation menu is
contained in the navigation bar.")
(license license:gpl2+)))
+(define-public r-spdl
+ (package
+ (name "r-spdl")
+ (version "0.0.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "spdl" version))
+ (sha256
+ (base32 "185qzlwac7acq126xpvcd71nv25zgkrdr8m73gv2sn1zxj78hyid"))))
+ (properties `((upstream-name . "spdl")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-rcppspdlog))
+ (home-page "https://github.com/eddelbuettel/spdl")
+ (synopsis "Easier use of RcppSpdlog functions via wrapper")
+ (description
+ "Logging functions in @code{RcppSpdlog} provide access to the logging
+functionality from the spdlog C++ library. This package offers shorter
+convenience wrappers for the R functions which match the C++ functions, namely
+via, say, @code{spdl::debug()} at the debug level. The actual formatting is
+done by the @code{fmt::format()} function from the fmtlib library (that is
+also @code{std::format()} in C++20 or later).")
+ (license license:gpl2+)))
+
(define-public r-spelling
(package
(name "r-spelling")