summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2025-02-11 16:38:30 +0100
committerRicardo Wurmus <[email protected]>2025-02-11 16:40:05 +0100
commite72b988cfb36f48ec8f43700fe0ad132acb98ca1 (patch)
tree5e02a3406166f53a89ed34b309b84e73c624ed8e /gnu/packages/bioinformatics.scm
parent1038c4da36a46d259f98ba1d6bc75cfb041d31ae (diff)
gnu: r-presto: Update to 1.0.0-1.7636b3d.
* gnu/packages/bioinformatics.scm (r-presto): Update to 1.0.0-1.7636b3d. [properties]: Fix typo. [propagated-inputs]: Remove r-deseq2 and r-reshape2; add r-purrr and r-tibble. [native-inputs]: Add r-knitr. Change-Id: I1285062405bd42b7f3162a44ccf7b174492e5201
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 6b2e552585..1ea6f697a1 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -13027,8 +13027,8 @@ states in the the context of known, reference states.")
(license license:gpl3))))
(define-public r-presto
- (let ((commit "052085db9c88aa70a28d11cc58ebc807999bf0ad")
- (revision "0"))
+ (let ((commit "7636b3d0465c468c35853f82f1717d3a64b3c8f6")
+ (revision "1"))
(package
(name "r-presto")
(version (git-version "1.0.0" revision commit))
@@ -13040,20 +13040,20 @@ states in the the context of known, reference states.")
(commit commit)))
(file-name (git-file-name name version))
(sha256
- (base32 "1c3fmag4r4p2lvbvxlxyck9dvfw1prbwcl9665mmlx4a35750hk8"))))
- (properties `((upstream . "presto")))
+ (base32 "07giligbadv3ap0p4hzsviqpgiipkqcq7x6p0g8lmb8xxpjz3y29"))))
+ (properties `((upstream-name . "presto")))
(build-system r-build-system)
(propagated-inputs
(list r-data-table
- r-deseq2
r-dplyr
r-matrix
+ r-purrr
r-rcpp
r-rcpparmadillo
- r-reshape2
r-rlang
+ r-tibble
r-tidyr))
- (native-inputs (list r-testthat))
+ (native-inputs (list r-knitr r-testthat))
(home-page "https://github.com/immunogenomics/presto")
(synopsis "Fast Functions for Differential Expression using Wilcox and AUC")
(description "This package performs a fast Wilcoxon rank sum test and