summaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-02-17 16:53:37 +0000
committerSharlatan Hellseher <[email protected]>2025-02-28 22:44:02 +0000
commit9ddd1861aeaae43eac80130b6335b193bffefde8 (patch)
treec197db57b104ceae211d50611783d8e55e149341 /gnu/packages/astronomy.scm
parent58fe8c97081b108170cabf6f63ecb69b2f9c7b9e (diff)
gnu: python-halotools: Update to 0.9.3.
* gnu/packages/astronomy.scm (python-halotools): Update to 0.9.3. [arguments] <phases>: Remove 'build-extensions and use custom 'check. Change-Id: Ia6ce0c7de0544c0a9ad071aa0ef5dd63ff57c544
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm16
1 files changed, 9 insertions, 7 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 516969fb3a..3147674ae8 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2830,23 +2830,25 @@ default) to world coordinates.")
(define-public python-halotools
(package
(name "python-halotools")
- (version "0.9.2")
+ (version "0.9.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "halotools" version))
(sha256
- (base32 "1fa4w8dabr0zx6xwnrdwdipf4s6sg7q25jmq42n9q8n64kjx60vb"))))
+ (base32 "004nqlyiv6gyzmjk840a1hl3j4sgi5xwbfibankwi7281gq4hx3d"))))
(build-system pyproject-build-system)
(arguments
(list
- ;; Tests are shaky in parallel.
#:phases
#~(modify-phases %standard-phases
- (add-before 'check 'build-extensions
- (lambda _
- (setenv "HOME" "/tmp")
- (invoke "python" "setup.py" "build_ext" "--inplace"))))))
+ ;; Use built library for tests.
+ (replace 'check
+ (lambda* (#:key tests? test-flags #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion #$output
+ (setenv "HOME" "/tmp")
+ (apply invoke "pytest" "-vv" test-flags))))))))
(native-inputs
(list python-cython-3
python-extension-helpers