summaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-02-12 18:16:27 +0000
committerSharlatan Hellseher <[email protected]>2025-02-28 22:44:00 +0000
commit6d6bcb631d67582bf01a1a5fc38803a73fc3fa2f (patch)
treeb1c846df2293225f94bc9f872b1cbbdd77f1540f /gnu/packages/astronomy.scm
parent9187e166e513f750a8079bed22352c3617e15fd6 (diff)
gnu: python-astropy: Simplify check phase.
* gnu/packages/astronomy.scm (python-astropy) [phases] {check}: Remove make file writable and build extension steps. Run tests from output, which provides access to built library. Change-Id: I87168de8197bed0c47274bca5fb3a92a02f5b845
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm8
1 files changed, 2 insertions, 6 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 230eb7f76c..d75c20f0d1 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -3729,14 +3729,10 @@ instruments.")
(lambda* (#:key tests? test-flags #:allow-other-keys)
(when tests?
(setenv "HOME" "/tmp")
- (make-file-writable "astropy/_compiler.c")
- ;; Extensions have to be rebuilt before running the tests.
- (invoke "python" "setup.py" "build_ext" "--inplace"
- "-j" (number->string (parallel-job-count)))
;; Step out of the source directory to avoid interference; we
;; want to run the installed code with extensions etc.
- (with-directory-excursion "/tmp"
- (apply invoke "pytest" "-v" test-flags))))))))
+ (with-directory-excursion #$output
+ (apply invoke "pytest" "-vv" test-flags))))))))
(native-inputs
(list nss-certs-for-test
pkg-config