summaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-02-21 18:11:24 +0000
committerSharlatan Hellseher <[email protected]>2025-02-28 22:44:05 +0000
commit3d34fde47f9039fcecbb338e45782722f10e5e36 (patch)
tree7181144d4946657f6393c2547c9cbf903d002644 /gnu/packages/astronomy.scm
parente95358b8cb8af6b5e05e1baffba90a0aec2aa9a4 (diff)
gnu: python-jwst-reffiles: Enable tests and sanity-check.
* gnu/packages/astronomy.scm (python-jwst-reffiles) [arguments] <tests?>: Enable them. <test-flags>: Skip one failing test. <phases>: Enable 'sanity-check. [native-inputs]: Remove python-stsci-stimage. Change-Id: Idcbcd4fd955ccfdfec88325d557ca979cb66a2dc
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm18
1 files changed, 5 insertions, 13 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 9ce7ca50f8..65890c3e9c 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -4517,25 +4517,17 @@ exposures and high-level data products (mosaics, extracted spectra, etc.).")
(build-system pyproject-build-system)
(arguments
(list
- ;; FIXME: Invistigate why it failes on python-jwst side where the
- ;; python-tweakwcs is built just fine:
- ;;
- ;; <...>/tweakwcs/matchutils.py:18: in <module>
- ;; from stsci.stimage import xyxymatch
- ;; E ModuleNotFoundError: No module named 'stsci.stimage'
- #:tests? #f
- #:phases
- #~(modify-phases %standard-phases
- (delete 'sanity-check))))
+ ;; One test fails with error: FileNotFoundError: [Errno 2] No such file
+ ;; or directory.
+ #:test-flags #~(list "-k" "not test_calib_prep_steps")))
+ (native-inputs
+ (list python-pytest))
(propagated-inputs
(list python-astropy
python-jwst
python-matplotlib
python-numpy
python-scipy))
- (native-inputs
- (list python-pytest
- python-stsci-stimage))
(home-page "https://github.com/spacetelescope/jwst_reffiles")
(synopsis "Tool for JWST's CRDS-formatted reference files creation")
(description