summaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-02-21 16:52:53 +0000
committerSharlatan Hellseher <[email protected]>2025-02-28 22:44:05 +0000
commit307431484ec555b64568c3bee78ebab58bee5c9b (patch)
tree2c040a682b3be6c9a6a7c72b8762c5620044399b /gnu/packages/astronomy.scm
parentefaf99a21e001df1f20076eed824f3e78c96d1b9 (diff)
gnu: python-stcal: Update to 1.11.1.
* gnu/packages/astronomy.scm (python-stcal): Update to 1.11.1. Fix build. [argumens] <test-flags>: Run tests in parallel. <phases>: Remove 'silent-check-for-opencv, add 'relax-requirements. [native-inputs]: Add python-pytest-xdist. Change-Id: I175d4fc3e52efdcad4eac0d8e05f7637245f8e92
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm19
1 files changed, 13 insertions, 6 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 683e9b90bc..928fe882c0 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -5740,18 +5740,19 @@ processing functions: @code{xyxymatch}, @code{geomap}.")
(define-public python-stcal
(package
(name "python-stcal")
- (version "1.10.0")
+ (version "1.11.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "stcal" version))
(sha256
- (base32 "1h0vkc3nd77qm2ph1nihpd1n7dzr3d4rw2wga6j7siqjiwmphj3g"))))
+ (base32 "0xafli4b3wyimpaxmvb0h5bha5g5kg76s4hykk63wkxrjrd2m2vf"))))
(build-system pyproject-build-system)
(arguments
(list
#:test-flags
- #~(list "-k" (string-join
+ #~(list "--numprocesses" (number->string (parallel-job-count))
+ "-k" (string-join
;; Tests requiring network access.
(list "not test_absolute_align"
"test_relative_align[True]"
@@ -5770,11 +5771,16 @@ processing functions: @code{xyxymatch}, @code{geomap}.")
;; contain the variable: error: ‘NPY_NTYPES_LEGACY’ undeclared
;; (first use in this function)
((".*NPY_NTYPES_LEGACY.*") ""))))
- (add-before 'build 'silent-check-for-opencv
+ (add-before 'build 'relax-requirements
(lambda _
- ;; XXX: Can't detect opencv-python version. The input opencv
- ;; might not set the version correctly.
(substitute* "pyproject.toml"
+ ;; Relax some requirements as all tests passed successfully.
+ ;; numpy>=1.25.0
+ (("1.25.0") "1.24.4")
+ ;; scipy>=1.14.1
+ (("1.14.1") "1.12.0")
+ ;; XXX: Can't detect opencv-python version. The input opencv
+ ;; might not set the version correctly.
((".*opencv-python-headless.*") ""))))
(add-before 'check 'build-extensions
(lambda _
@@ -5784,6 +5790,7 @@ processing functions: @code{xyxymatch}, @code{geomap}.")
(list python-cython-3
python-psutil
python-pytest
+ python-pytest-xdist
python-pytest-doctestplus
python-setuptools
python-setuptools-scm