summaryrefslogtreecommitdiff
path: root/gnu/packages/adns.scm
diff options
context:
space:
mode:
authorJelle Licht <[email protected]>2025-01-05 18:57:19 +0100
committerJelle Licht <[email protected]>2025-02-11 14:02:51 +0100
commite59a6253881f8b13173cc6911e4932ea75c6a15b (patch)
tree608492a1e652d950086afbc698f11c1ee2d68471 /gnu/packages/adns.scm
parenta10dda503b243be7a2ebdba98eca0e84c6975aee (diff)
gnu: Add c-ares-for-node-lts.
* gnu/packages/adns.scm (c-ares-for-node-lts): New variable. Change-Id: I547272f3fa3419a7659bf5b2d91a3e917c20d434
Diffstat (limited to 'gnu/packages/adns.scm')
-rw-r--r--gnu/packages/adns.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/adns.scm b/gnu/packages/adns.scm
index 1097b84062..8f37d970c3 100644
--- a/gnu/packages/adns.scm
+++ b/gnu/packages/adns.scm
@@ -148,6 +148,21 @@ The primary examples of such applications are servers which communicate with
multiple clients and programs with graphical user interfaces.")
(license (x11-style "https://c-ares.haxx.se/license.html"))))
+(define-public c-ares-for-node-lts
+ (hidden-package
+ (package
+ (inherit c-ares)
+ (version "1.34.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/c-ares/c-ares/releases/download/v"
+ version "/c-ares-" version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0br2msk3bpl5myhjp9vr5j2scpspvbg2fpnz69dcrr4ycpnxnf7s")))))))
+
;; gRPC requires a c-ares built with CMake in order to get the .cmake modules.
;; We can not build c-ares itself with CMake because that would introduce a
;; circular dependency through nghttp2.