summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEfraim Flashner <[email protected]>2025-02-06 16:12:16 +0200
committerEfraim Flashner <[email protected]>2025-03-02 16:46:59 +0200
commit38de9218d65f054f73b588c2b901afe858d46d15 (patch)
tree2818b760d89ba4043ef281aeab01b08d304ea059 /Makefile.am
parent50d9b8c0b75326a640678181ec23ac7820a0db47 (diff)
Makefile.am: Clarify the label for systems supported by the installer.
* Makefile.am (GUIX_SYSTEM_SUPPORTED_SYSTEMS): Rename to GUIX_SYSTEM_INSTALLER_SYSTEMS. Change-Id: I5c15e6916583bcd56e535733f284f3a735d7600b
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 64b5bbad14..c668b96a37 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1083,8 +1083,9 @@ SUPPORTED_SYSTEMS ?= x86_64-linux i686-linux armhf-linux aarch64-linux \
BINARY_TARBALLS = \
$(foreach system,$(SUPPORTED_SYSTEMS),guix-binary.$(system).tar.xz)
-# Systems supported by Guix System.
-GUIX_SYSTEM_SUPPORTED_SYSTEMS ?= x86_64-linux i686-linux
+# Systems supported by the Guix System installer.
+# A Hurd install happens from a Linux installer image.
+GUIX_SYSTEM_INSTALLER_SYSTEMS ?= x86_64-linux i686-linux
# Systems for which we build Guix VMs.
GUIX_SYSTEM_VM_SYSTEMS ?= x86_64-linux
@@ -1145,10 +1146,10 @@ release: dist-with-updated-version all
# Build 'current-guix' to speed things up for the next step.
$(top_builddir)/pre-inst-env guix build \
-e '((@ (gnu packages package-management) current-guix))' \
- $(call system_flags,$(GUIX_SYSTEM_SUPPORTED_SYSTEMS)) \
+ $(call system_flags,$(GUIX_SYSTEM_INSTALLER_SYSTEMS)) \
-v1 --no-grafts --fallback
# Generate the ISO installation images.
- for system in $(GUIX_SYSTEM_SUPPORTED_SYSTEMS) ; do \
+ for system in $(GUIX_SYSTEM_INSTALLER_SYSTEMS) ; do \
GUIX_DISPLAYED_VERSION="`git describe --match=v* | sed -'es/^v//'`" ; \
image=`$(top_builddir)/pre-inst-env \
guix system image -t iso9660 \
@@ -1212,7 +1213,7 @@ assert-no-store-file-names:
exit 1 ; \
fi
-# Make sure important substitutes are available. Check only the primary
+# Make sure installer substitutes are available. Check only the primary
# server so that '--display-missing' doesn't print two lists.
assert-binaries-available: $(GOBJECTS)
$(AM_V_at)$(top_builddir)/pre-inst-env \