summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHikari <[email protected]>2024-12-07 10:22:44 +0000
committerZheng Junjie <[email protected]>2025-01-27 19:53:01 +0800
commitfcd7c7dcadde2c4293cf56145d44183a24b2a6df (patch)
tree3d8cd213eb2a927d799bf93934d8f5d96daa22e4
parent9fc3233d60af0cc4f30b0d8306da9ef16301aff7 (diff)
gnu: Add wideriver.
* gnu/packages/wm.scm (wideriver): New variable. Change-Id: Iab2a6bd8bd02098105848d240af0271df44b58bf
-rw-r--r--gnu/packages/wm.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index cc5da92eef..614d74bd1a 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -4174,6 +4174,37 @@ for short) for X11 and Wayland, that goes to great lengths to be both CPU and
battery efficient---polling is only done when absolutely necessary.")
(license license:expat)))
+(define-public wideriver
+ (package
+ (name "wideriver")
+ (version "1.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alex-courtis/wideriver")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "16i0mzgxn32nrh5ajn0kb4xdwmsjg03amhasxhwyvspar5y4flhg"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:test-target "test"
+ #:make-flags
+ #~(list (string-append "PREFIX=" #$output)
+ (string-append "CC=" #$(cc-for-target)))
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure)))) ; no configure script
+ (native-inputs (list pkg-config cmocka))
+ (inputs (list wayland wayland-protocols wlroots))
+ (home-page "https://github.com/alex-courtis/wideriver")
+ (synopsis "A set of riverWM layouts")
+ (description
+ "Tiling window manager for the river wayland compositor, inspired by dwm
+and xmonad.")
+ (license license:gpl3)))
+
(define-public wf-config
(package
(name "wf-config")