summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2025-01-03 15:42:57 +0100
committerRicardo Wurmus <[email protected]>2025-01-20 21:37:33 +0100
commitee8dd12393b2585525e1e1c7391a9c5733cad30b (patch)
tree55c1e9c694191e6dc1469d6d14517bc3c1517cce
parenta85358775f98b8826f03797764049542c5e98067 (diff)
gnu: python-pillow: Use pyproject-build-system.
* gnu/packages/python-xyz.scm (python-pillow)[build-system]: Use pyproject-build-system. [native-inputs]: Add python-setuptools and python-wheel. Change-Id: I98b8c79664ede2ef3d8f3e9a2321289da8719d9b
-rw-r--r--gnu/packages/python-xyz.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1b4555640a..628609b807 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11002,8 +11002,8 @@ Python list with elements of type @code{PIL.Image} (from the
(search-patches "python-pillow-CVE-2022-45199.patch"
;; Included in 10.1.0.
"python-pillow-use-zlib-1.3.patch"))))
- (build-system python-build-system)
- (native-inputs (list python-pytest))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-pytest python-setuptools python-wheel))
(inputs (list freetype
lcms
libjpeg-turbo