summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-28 19:58:51 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:42:34 +0000
commitedb7c039252a1da3f8d4a1459059d05e33d57b68 (patch)
tree2384103678a439b2186be65431ccb523b917e694
parentee10c24389d63870e922d656e67b2c40db7c8b94 (diff)
gnu: Add go-github-com-arbovm-levenshtein.
* gnu/packages/golang-xyz.scm (go-github-com-arbovm-levenshtein): New variable. Change-Id: I6eb61438459cccf23e0d9b49b9691a4498e36441
-rw-r--r--gnu/packages/golang-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 11ae405097..9dc8097be1 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -936,6 +936,31 @@ commands.")
"This package implements optimal parameters for data-types.")
(license license:expat)))
+(define-public go-github-com-arbovm-levenshtein
+ (package
+ (name "go-github-com-arbovm-levenshtein")
+ (version "0.0.0-20160628152529-48b4e1c0c4d0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/arbovm/levenshtein")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0nmx2iip8xpnbmy6gvqpc9ikizr33dr40xgv746h0b0by8n7rv7y"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/arbovm/levenshtein"))
+ (home-page "https://github.com/arbovm/levenshtein")
+ (synopsis "Levenshtein Distance in Golang")
+ (description
+ "This package implements a functionality to calculate the
+@url{http://en.wikipedia.org/wiki/Levenshtein_distance, Levenshtein
+Distance}.")
+ (license license:bsd-3)))
+
(define-public go-github-com-arceliar-phony
(package
(name "go-github-com-arceliar-phony")