summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2025-01-07 20:51:58 +0100
committerRicardo Wurmus <[email protected]>2025-01-20 21:37:37 +0100
commitec9173dbcb5a2c7111638db5e0b3451f46b1e042 (patch)
tree243663e26203e19cdf67ead340bafff02a6cb9ce
parentd2ad0b98c55ba1697c79daad7f8bc35fb45fee26 (diff)
gnu: python-mudata: Update to 0.3.1.
* gnu/packages/bioinformatics.scm (python-mudata): Update to 0.3.1. [arguments]: Add phase 'pretend-version. [native-inputs]: Remove python-flit-core; add python-hatch-vcs and python-hatchling. Change-Id: I87b8dc6ec557e0ca69930d82db7d6e64727228e9
-rw-r--r--gnu/packages/bioinformatics.scm17
1 files changed, 14 insertions, 3 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index c94e87fe61..5daae49574 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4930,7 +4930,7 @@ with MOFA+ in Python.")
(define-public python-mudata
(package
(name "python-mudata")
- (version "0.2.3")
+ (version "0.3.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -4939,12 +4939,23 @@ with MOFA+ in Python.")
(file-name (git-file-name name version))
(sha256
(base32
- "02h0k1q57589r0hdv8nwg1vk7g2ljvn5g66c47fy5gdilbm3gjws"))))
+ "1m1qsqgk8snllavfj99qgm2j7cccviwg7k0k1kfbvqn0bkzc87sa"))))
(build-system pyproject-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'pretend-version
+ (lambda _
+ (setenv "SETUPTOOLS_SCM_PRETEND_VERSION" #$version))))))
(propagated-inputs
(list python-anndata python-h5py python-pandas))
(native-inputs
- (list python-flit-core python-numpy python-pytest python-zarr))
+ (list python-hatch-vcs
+ python-hatchling
+ python-numpy
+ python-pytest
+ python-zarr))
(home-page "https://github.com/scverse/mudata")
(synopsis "Python package for multi-omics data analysis")
(description