summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2025-01-05 13:41:57 +0100
committerRicardo Wurmus <[email protected]>2025-01-20 21:37:36 +0100
commite3a69f37cacba3bc7526259bd41eea3ea2c614a7 (patch)
treedefc037098c4faa0ccd27f17c57a6c13a60f42db
parenta8f747c012386eb21e0425c4254283c8424d0dc3 (diff)
gnu: python-wrapt: Update to 1.17.0.
* gnu/packages/python-xyz.scm (python-wrapt): Update to 1.17.0. [arguments]: Enable tests. [native-inputs]: Add python-pytest, python-setuptools, and python-wheel. Change-Id: Ib2e973ec7b09454588bbbbdd5d8446afc53e835b
-rw-r--r--gnu/packages/python-xyz.scm11
1 files changed, 4 insertions, 7 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 604922ffed..163859388c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16705,19 +16705,16 @@ list format (also known as ASCII plist), written in Cython.")
(define-public python-wrapt
(package
(name "python-wrapt")
- (version "1.11.2")
+ (version "1.17.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "wrapt" version))
(sha256
(base32
- "1q81762dgsgrd12f8qc39zk8s5wll3m5xc32jdmlf6cls4gh4njn"))))
- (build-system python-build-system)
- (arguments
- ;; Tests are not included in the tarball, they are only available in the
- ;; git repository.
- `(#:tests? #f))
+ "00886b7ry1vdbvpc2wi880y563xf6y4mxwwfm1q12wvw66i7l60n"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-pytest python-setuptools python-wheel))
(home-page "https://github.com/GrahamDumpleton/wrapt")
(synopsis "Module for decorators, wrappers and monkey patching")
(description