summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <[email protected]>2025-02-02 01:44:26 +0100
committerDanny Milosavljevic <[email protected]>2025-02-02 01:44:26 +0100
commite16d89d4c0ffcceaa89a29dbabd4a382d9a01375 (patch)
treefe057d91f4e2ff0a57570b5e625c6e6dc2a66596
parent3dd408f6aab959b527b3155c5249d18ccdc71651 (diff)
gnu: Add go-github-com-agnivade-levenshtein.
* gnu/packages/golang-xyz.scm (go-github-com-agnivade-levenshtein): New variable. Change-Id: I71383dd703bb9418db184cd4fd0f2fd82a907a48
-rw-r--r--gnu/packages/golang-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 625b5c9b70..a121d93ba1 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -17879,6 +17879,31 @@ converting them to the often much more useful @@code{time.Duration}.")
#:unpack-path "github.com/dgryski/trifles"
#:import-path "github.com/dgryski/trifles/leven"))))
+(define-public go-github-com-agnivade-levenshtein
+ (package
+ (name "go-github-com-agnivade-levenshtein")
+ (version "1.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/agnivade/levenshtein")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0vg9aj9k4qv96nqqp261qrm9g7kj0axqhv3mm9qvw932l72943hn"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/agnivade/levenshtein"))
+ (propagated-inputs (list go-github-com-dgryski-trifles-leven
+ go-github-com-arbovm-levenshtein))
+ (home-page "https://github.com/agnivade/levenshtein")
+ (synopsis "Levenshtein Distance")
+ (description
+ "This package provides a Go implementation to calculate Levenshtein
+Distance.")
+ (license license:expat)))
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar