summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2025-01-02 20:13:16 +0100
committerRicardo Wurmus <[email protected]>2025-01-20 21:37:31 +0100
commitdb9b46ad53a5c3bfa2e4ba59af24611fddb853da (patch)
tree227ea71fa0271a4ab81fd2b22833dd134075c253
parente268c084d73ee1b2f804721ba5c0e86dcf0ac25f (diff)
gnu: python-jose: Fix build.
* gnu/packages/python-web.scm (python-jose)[build-system]: Use pyproject-build-system. [arguments]: Disable some failing tests; remove custom 'check phase. [native-inputs]: Add python-setuptools and python-wheel. Change-Id: I39831da68beb6e7e80cd97df04310676e2cdf92a
-rw-r--r--gnu/packages/python-web.scm22
1 files changed, 12 insertions, 10 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index c956f1f949..4e7545b86e 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1778,20 +1778,22 @@ Swartz.")
(sha256
(base32
"18whsdpllg8574ma4r0qawkgw4nam6lsf63pi6761j38rvl84lg9"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (if tests?
- (invoke "pytest" "-vv")
- (format #t "test suite not run~%"))
- #t)))))
+ (list
+ #:test-flags
+ '(list "-k"
+ ;; These fail because of unexpected locations of line breaks.
+ (string-append "not test_public_key_to_pem "
+ "and not test_private_key_to_pem "
+ "and not test_public_key_load_cycle "
+ "and not test_private_key_load_cycle"))))
(native-inputs
(list ;; All native inputs are for tests.
python-pyasn1 python-pytest python-pytest-cov
- python-pytest-runner))
+ python-pytest-runner
+ python-setuptools
+ python-wheel))
(propagated-inputs
(list python-cryptography python-ecdsa python-rsa python-six))
(synopsis "JOSE implementation in Python")