summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2024-12-29 17:25:13 +0100
committerRicardo Wurmus <[email protected]>2025-01-20 21:37:28 +0100
commitd918e0e6095eea89b1865e381ca2da78a2ec141c (patch)
treeff16c1e36012eaeef63eb2e99ccabebc25b19dce
parent80106ec31978a526628a107e213c6f3e990d7494 (diff)
gnu: python-trio: Update to 0.28.0.
* gnu/packages/python-xyz.scm (python-trio): Update to 0.28.0. [arguments]: Add phase 'ignore-deprecations. [native-inputs]: Remove python-astor, python-jedi, python-isort, and python-pytest-asyncio. [propagated-inputs]: Remove python-async-generator. Change-Id: I435fe322324bc5e58130d072db7f032c3a67c67e
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 9 insertions, 10 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c6831b0249..e36979be71 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -30444,13 +30444,13 @@ project.")
(define-public python-trio
(package
(name "python-trio")
- (version "0.27.0")
+ (version "0.28.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "trio" version))
(sha256
- (base32 "0cb8qy1yj274xa21nf2jpmwssjzp39vgva7y982xmci62ymrbk0x"))))
+ (base32 "019wqwlbj185skknbjd7paxqqx6vl5gpqk2fwmc5d2lyzsb7hm2f"))))
(build-system pyproject-build-system)
(arguments
(list
@@ -30492,6 +30492,10 @@ _cyclic_garbage"
"src/trio/_tests")
#:phases
'(modify-phases %standard-phases
+ (add-after 'unpack 'ignore-deprecations
+ (lambda _
+ (substitute* "pyproject.toml"
+ ((" \"error\",") " \"ignore\","))))
(add-before 'check 'set-env
(lambda _
;; Tests require a writable home.
@@ -30499,18 +30503,13 @@ _cyclic_garbage"
;; #$output is first in path which causes "import file mismatch"
(setenv "PYTHONPATH" (string-append (getcwd) "/src:$PYTHONPATH")))))))
(native-inputs
- (list python-astor
- python-jedi
- python-pyopenssl
+ (list python-pyopenssl
python-pytest
- python-isort
- python-pytest-asyncio
- python-trustme
python-setuptools
+ python-trustme
python-wheel))
(propagated-inputs
- (list python-async-generator
- python-attrs
+ (list python-attrs
python-cffi
python-exceptiongroup
python-idna