summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVagrant Cascadian <[email protected]>2025-01-23 00:56:40 -0800
committerVagrant Cascadian <[email protected]>2025-02-11 11:45:01 -0800
commitd3201247713f4de6d78b899ef6d9014fa9dfc542 (patch)
treeeed0c83f9ae9e4960ce7056e219ae2168111d334
parentb30669e15d2e8c3d1b74b32f77e2095682aab4ca (diff)
gnu: grub-minimal, grub-efi: Reduce unused native-inputs.
"qemu" was removed in e9c1ea84fcf4a7f3da9aea9fbfe6136c75643c07 in the code though the commit message claims to have removed "qemu-minimal". If that worked, it may have been broken by switching away from labels in b9c38f26f120e3e12b3bfbf29c6248a08fe1a62c. * gnu/packages/bootloaders.scm (grub-minimal)[native-inputs]: Remove qemu-minimal. (grub-efi)[native-inputs]: Remove qemu-minimal.
-rw-r--r--gnu/packages/bootloaders.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index b5cfacca4b..4dab7bd0b7 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -323,7 +323,7 @@ menu to select one of the installed operating systems.")
(delete "lvm2" "mdadm" "fuse" "console-setup")))
(native-inputs
(modify-inputs (package-native-inputs grub)
- (delete "help2man" "texinfo" "parted" "qemu" "xorriso")))
+ (delete "help2man" "texinfo" "parted" "qemu" "qemu-minimal" "xorriso")))
(arguments
(substitute-keyword-arguments (package-arguments grub)
((#:tests? _ #t) #f)
@@ -413,7 +413,7 @@ menu to select one of the installed operating systems.")
(native-inputs
;; The tests are skipped in this package so we remove some test dependencies.
(modify-inputs (package-native-inputs grub)
- (delete "parted" "qemu" "xorriso")))
+ (delete "parted" "qemu" "qemu-minimal" "xorriso")))
(arguments
;; TODO: Tests need a UEFI firmware for qemu. There is one at
;; https://github.com/tianocore/edk2/tree/master/OvmfPkg .