summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2025-01-13 13:56:13 +0100
committerRicardo Wurmus <[email protected]>2025-01-13 14:00:50 +0100
commitd0268d5b7ff4c5bac0ac2e25bc371ba5c950d12a (patch)
tree2fde9eb8308da6d85bfb3250ad65e23101b9c99b
parenta3615c0c743c3048e004fae426443c4abea9a477 (diff)
gnu: Add python-jupyter-lsp.
* gnu/packages/jupyter.scm (python-jupyter-lsp): New variable. Change-Id: I685e289e5e24e049d1b111061bfd79fdca15d6c9
-rw-r--r--gnu/packages/jupyter.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/jupyter.scm b/gnu/packages/jupyter.scm
index e4b7629a9f..3b7f8dde1f 100644
--- a/gnu/packages/jupyter.scm
+++ b/gnu/packages/jupyter.scm
@@ -135,6 +135,38 @@ the namespace @code{/nbclassic/}.")
to Jupyter Server for their Python Web application backend.")
(license license:bsd-3)))
+(define-public python-jupyter-lsp
+ (package
+ (name "python-jupyter-lsp")
+ (version "2.2.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "jupyter-lsp" version))
+ (sha256
+ (base32 "00ahai7wp0m98glpqsrd1bymcllzkb8irvskzl4zhinlbah4fcbr"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags
+ ;; No R language server is present.
+ '(list "-k" "not test_r_package_detection")
+ #:phases
+ '(modify-phases %standard-phases
+ ;; Some tests require a writable HOME
+ (add-before 'check 'set-HOME
+ (lambda _ (setenv "HOME" "/tmp"))))))
+ (propagated-inputs (list python-jupyter-server))
+ (native-inputs (list python-pytest python-setuptools python-wheel))
+ (home-page "https://pypi.org/project/jupyter-lsp/")
+ (synopsis "Multi-Language Server WebSocket proxy for Jupyter Notebook/Lab server")
+ (description
+ "This package provides a multi-language server WebSocket proxy for
+Jupyter Notebook/Lab server. It provides coding assistance for
+JupyterLab (code navigation, hover suggestions, linters, autocompletion, and
+rename) using the Language Server Protocol.")
+ (license license:bsd-3)))
+
(define-public python-jupyter-protocol
(package
(name "python-jupyter-protocol")