summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDivya Ranjan <[email protected]>2025-01-01 15:29:19 +0000
committerNicolas Goaziou <[email protected]>2025-01-03 11:59:36 +0100
commitce3ffac5d366ebf20e0d95779f2fe1ea6dde0202 (patch)
tree08182e577d57bbd09eaffd05b827b87cd9465e97
parent9b880589939edbcf10aa6fcbef0d96a973357d44 (diff)
gnu: Add emacs-binder.
* gnu/packages/emacs-xyz.scm (emacs-binder): New variable. Signed-off-by: Nicolas Goaziou <[email protected]> Change-Id: I5c2c0526ad9c12c2797ae5239b0ae2d762ea51af
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 23 insertions, 1 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index de7158eb4c..61b6ddf383 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -150,7 +150,7 @@
;;; Copyright © 2024 Liam Hupfer <[email protected]>
;;; Copyright © 2024 aurtzy <[email protected]>
;;; Copyright © 2024 Olivier Rojon <[email protected]>
-
+;;; Copyright © 2024 Divya Ranjan Pattanaik <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -39825,6 +39825,28 @@ of a leader key as used in Vim or the @code{emacs-evil-leader} package,
and allows for an arbitrary number of leader keys.")
(license license:gpl3+))))
+(define-public emacs-binder
+ (package
+ (name "emacs-binder")
+ (version "0.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/divyaranjan/binder")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ "1fdgl31zc15cysv1yys95j0106i2fwfxb3qcwwh7f3mcz2snr2md")))
+ (build-system emacs-build-system)
+ (home-page "https://codeberg.org/divyaranjan/binder")
+ (synopsis
+ "Binder is a global minor mode to facilitate working on multiple files")
+ (description
+ "Primarily, Binder provides a global minor mode Binder Mode.
+This allows working with files in the current @code{binder-project-directory}.")
+ (license license:gpl3+)))
+
(define-public emacs-spaceleader
(let ((commit "5d88d120494623d6777d464ec40ff4bb7d6b1d57")
(revision "1"))