summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAshish SHUKLA <[email protected]>2024-12-31 19:11:55 +0000
committerZheng Junjie <[email protected]>2025-01-02 20:55:18 +0800
commitcc5bf71eb9c0226915805ee88b4212559c65e8bb (patch)
tree66a222425e91aa16fdaf2e496478e62ce39d01cb
parentf5e8c2e1b227047b8425a98172d59d21a27f5143 (diff)
gnu: radvd: Update to 2.20.
* gnu/packages/admin.scm (radvd): Update to 2.20. [inputs]: Add libbsd. Change-Id: I50a6359c18746afb51aa3250acf2222e674a290e Signed-off-by: Zheng Junjie <[email protected]>
-rw-r--r--gnu/packages/admin.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index dce93e4f3a..0be8671d45 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -70,6 +70,7 @@
;;; Copyright © 2024 Vinicius Monego <[email protected]>
;;; Copyright © 2024 nathan <[email protected]>
;;; Copyright © 2024 Nikita Domnitskii <[email protected]>
+;;; Copyright © 2024 Ashish SHUKLA <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1714,7 +1715,7 @@ maintenance releases.")
(define-public radvd
(package
(name "radvd")
- (version "2.19")
+ (version "2.20")
(source
(origin
(method git-fetch)
@@ -1723,7 +1724,7 @@ maintenance releases.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1df827m3vkjq2bcs5y9wg2cygvpdwl8ppl446qqhyym584gz54nl"))))
+ (base32 "090b8953cq7pvxf8i5wsippsi3zc8jxy559k6jpfjjmbbvl8zlmk"))))
(build-system gnu-build-system)
(native-inputs
(list autoconf
@@ -1732,6 +1733,7 @@ maintenance releases.")
check
flex
pkg-config))
+ (inputs (list libbsd))
(arguments
`(#:configure-flags '("--with-check")))
(home-page "https://radvd.litech.org/")