summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArtyom V. Poptsov <[email protected]>2024-12-31 17:36:17 +0300
committerArtyom V. Poptsov <[email protected]>2024-12-31 17:38:23 +0300
commitcb96b84c0edec0dd5ece774e1ee89f36103b4497 (patch)
tree031befd057e9d372fff755cd5e5ab9ae0ec3cd12
parent833fa80f17dde657bf4712824ae7bcb6b6302913 (diff)
gnu: tuir: Fix build.
* gnu/packages/syndication.scm (tuir): Fix build. [arguments] <#:test-flags>: Disable tests that require "/etc/ssl/certs/ca-certificates.crt" and networking. Change-Id: I7c75e384c11300a3c4e339f8f00b7d07fd3ec07d
-rw-r--r--gnu/packages/syndication.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/syndication.scm b/gnu/packages/syndication.scm
index faccc2129b..fdd67a8aa2 100644
--- a/gnu/packages/syndication.scm
+++ b/gnu/packages/syndication.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2022 Liliana Marie Prikler <[email protected]>
;;; Copyright © 2023 Maxim Cournoyer <[email protected]>
;;; Copyright © 2024 Luis Guilherme Coelho <[email protected]>
+;;; Copyright © 2024 Artyom V. Poptsov <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -519,7 +520,16 @@ a simple interface that makes it easy to organize and browse feeds.")
(build-system pyproject-build-system)
(arguments
(list #:test-flags
- '(list "-k" "not test_content_humanize_timestamp")
+ ;; Some tests require "/etc/ssl/certs/ca-certificates.crt" which is not
+ ;; available during the tests; also likely those tests require networking.
+ #~(list "-k" (string-append "not test_content"
+ " and not test_inbox"
+ " and not test_mime_parsers"
+ " and not test_oauth"
+ " and not test_page"
+ " and not test_submission"
+ " and not test_subreddit"
+ " and not test_subscription"))
#:phases
#~(modify-phases %standard-phases
(delete 'sanity-check)))) ; Reads environment variables.