summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2025-01-03 09:55:33 +0100
committerRicardo Wurmus <[email protected]>2025-01-20 21:37:32 +0100
commitca48ba11b5da4d40350bce4823fc0dbb94cfd257 (patch)
tree0c2d0400c416fb63a31dba6f058abff49f1bc76f
parentf2a1834249efc83fa23d85fa3260904a2ad0f58b (diff)
gnu: python-google-auth: Update to 2.37.0.
* gnu/packages/python-web.scm (python-google-auth): Update to 2.37.0. [build-system]: Use pyproject-build-system. [arguments]: Remove custom 'check phase; ignore one broken test. [propagated-inputs]: Remove python-cryptography and python-six; add python-pyjwt. [native-inputs]: Add python-aioresponses, python-cryptography, python-pytest-asyncio, python-setuptools, and python-wheel; remove python-oauth2client. Change-Id: I584ccab1fab97f5ba6efb2c5dba9e97f5186c415
-rw-r--r--gnu/packages/python-web.scm29
1 files changed, 15 insertions, 14 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 543832de46..cca59e8218 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -8766,39 +8766,40 @@ of the CRC32C hashing algorithm.")
(define-public python-google-auth
(package
(name "python-google-auth")
- (version "2.34.0")
+ (version "2.37.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "google_auth" version))
(sha256
- (base32 "1k04kkg5n3pi4awjxxsa50ail68wwf2gklmb686v46aw8fb77f4f"))))
- (build-system python-build-system)
+ (base32 "002xvp1139lrw2c2s2yllg5499ghfxzg9lv35i4q770zpwx64m00"))))
+ (build-system pyproject-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest")))))))
+ (list
+ #:test-flags
+ ;; This one test uses crypto.sign with an outdated calling convention.
+ '(list "--ignore=tests/transport/test__mtls_helper.py")))
(propagated-inputs
(list python-cachetools
- python-cryptography
python-pyasn1-modules
- python-rsa
- python-six))
+ python-pyjwt
+ python-rsa))
(native-inputs
(list nss-certs-for-test
+ python-aioresponses
+ python-cryptography
python-flask
python-freezegun
python-mock
- python-oauth2client
python-pyopenssl
python-pytest
+ python-pytest-asyncio
python-pytest-localserver
python-pyu2f
python-requests
- python-responses))
+ python-responses
+ python-setuptools
+ python-wheel))
(home-page "https://github.com/googleapis/google-auth-library-python")
(synopsis "Google Authentication Library")
(description "This library simplifies using Google's various