summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Čech <[email protected]>2025-01-18 00:15:07 +0100
committer宋文武 <[email protected]>2025-01-28 13:07:17 +0800
commitb3ccf0fb5426483779af0cedad3544fcb804c639 (patch)
tree34b98a85926f4e229ce12ee3d477f934c442d8df
parentf793fd557718ed00bcb0d9721a06ee9c9c619bf0 (diff)
gnu: Add xfce4-i3-workspaces-plugin.
* gnu/packages/xfce.scm (xfce4-i3-workspaces-plugin): New variable. Signed-off-by: 宋文武 <[email protected]> Change-Id: Iab03c16391290963db5f834f7b4d72f02d270f41
-rw-r--r--gnu/packages/xfce.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 43722cf484..7a7e2b3a1e 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -16,6 +16,7 @@
;;; Copyright © 2020, 2021, 2022 Michael Rohleder <[email protected]>
;;; Copyright © 2021, 2022 Brendan Tildesley <[email protected]>
;;; Copyright © 2021 André A. Gomes <[email protected]>
+;;; Copyright © 2025 Tomáš Čech <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -590,6 +591,31 @@ keys for controlling the audio volume.")
(license gpl2+)
(properties `((release-tag-prefix . ,(string-append name "-"))))))
+(define-public xfce4-i3-workspaces-plugin
+ (package
+ (name "xfce4-i3-workspaces-plugin")
+ (version "1.4.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/denesb/xfce4-i3-workspaces-plugin")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1l957xzs479mnl1la6lx3ysaiqc0z8l84jg442wif9k8x9z6iah8"))))
+ (build-system gnu-build-system)
+ (native-inputs (list xfce4-dev-tools))
+ (inputs (list i3ipc-glib libxfce4ui xfce4-panel))
+ (home-page "https://github.com/denesb/xfce4-i3-workspaces-plugin")
+ (synopsis "Xfce panel workspace switcher plugin for the i3 window manager")
+ (description
+ "This plugin is designed for switching workspaces and displaying which screen is
+currently visible, as well as indicating which workspace has a window requiring
+attention. Although it is intended for the Xfce4 panel, it is custom-built to work
+seamlessly with the tiling window manager i3.")
+ (license gpl3+)))
+
(define-public xfce4-whiskermenu-plugin
(package
(name "xfce4-whiskermenu-plugin")