summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2025-01-03 12:25:59 +0100
committerRicardo Wurmus <[email protected]>2025-01-20 21:37:33 +0100
commitadef506aca11877d7545f81a099bf94dde193128 (patch)
treebf666dbd236cc26ac259941a51682304c57390e9
parent2bad5ec127b36b60e42db030f6087942cbe65b45 (diff)
gnu: awscli-2: Remove obsolete build phase.
* gnu/packages/python-web.scm (awscli-2)[arguments]: Remove phase 'remove-pep517. Change-Id: Ibf05ea4f3ba93ea070bc29c3524be3b246f55708
-rw-r--r--gnu/packages/python-web.scm9
1 files changed, 0 insertions, 9 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 901136552f..998d8a5936 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4706,15 +4706,6 @@ Services (AWS) API.")
(lambda _
(substitute* "pyproject.toml"
(("\"error::") "\"ignore::"))))
- (add-after 'unpack 'remove-pep517
- (lambda _
- (rename-file "backends/pep517.py" "backends/dummypep517.py")
- (substitute* "pyproject.toml"
- (("pep517") "dummypep517"))
- (setenv "PYTHONPATH"
- (string-append (getcwd) ":"
- (getcwd) "/backends:"
- (getenv "GUIX_PYTHONPATH")))))
(add-after 'unpack 'fix-reference-to-groff
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "awscli/help.py"