summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <[email protected]>2025-01-15 01:47:28 -0800
committerLudovic Courtès <[email protected]>2025-01-28 14:56:13 +0100
commitac728b148fce4cbd1e1c2218ec8826f2aec5a0c4 (patch)
treee9f6a844d083d9ce39b5ef8593cc65b540710e76
parent49a113e3fc618d6f6bd5000c164a1d33701a30c4 (diff)
gnu: lapack: Update to 3.12.0.
* gnu/packages/maths.scm (lapack): Update to 3.12.0 and switch to ‘git-fetch’. [inputs]: Remove labels. Change-Id: I3ae813f55ddd3229b9924853cdb8c31c4e420112 Co-authored-by: Andy Tai <[email protected]>
-rw-r--r--gnu/packages/maths.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 1e9de1f38c..22e5f82d71 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -12,7 +12,7 @@
;;; Copyright © 2015 Fabian Harfert <[email protected]>
;;; Copyright © 2016 Roel Janssen <[email protected]>
;;; Copyright © 2016, 2018, 2020, 2021 Kei Kebreau <[email protected]>
-;;; Copyright © 2016-2024 Ludovic Courtès <[email protected]>
+;;; Copyright © 2016-2025 Ludovic Courtès <[email protected]>
;;; Copyright © 2016 Leo Famulari <[email protected]>
;;; Copyright © 2016, 2017 Thomas Danckaert <[email protected]>
;;; Copyright © 2017, 2018, 2019, 2020, 2021 Paul Garlick <[email protected]>
@@ -1168,19 +1168,20 @@ large scale eigenvalue problems.")
(define-public lapack
(package
(name "lapack")
- (version "3.9.0")
+ (version "3.12.1")
(source
(origin
- (method url-fetch)
- (uri (string-append "http://www.netlib.org/lapack/lapack-"
- version ".tgz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Reference-LAPACK/lapack/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1155qixp26c12yrxc76z9mlfw2h3xxymxxv5znpgzh5gaykpndgj"))))
+ "19387ifv5kplnggw5fgz4nzspmqi11wnwzap2knwxgrvknysrwj9"))))
(build-system cmake-build-system)
(home-page "https://www.netlib.org/lapack/")
- (inputs `(("fortran" ,gfortran)
- ("python" ,python-wrapper)))
+ (inputs (list gfortran python-wrapper))
(arguments
`(#:configure-flags (list
"-DBUILD_SHARED_LIBS:BOOL=YES"