summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <[email protected]>2020-11-11 17:22:07 +0200
committerEfraim Flashner <[email protected]>2020-11-11 22:49:22 +0200
commita13063d6ac7434beed1c608ce3eb6fb39c740b33 (patch)
tree0ff93978832f18846072d2e2ba80d7a7ab504294
parent4ce58ac0edad000aa116c309b512c6c6e6549ff3 (diff)
gnu: sbcl-cffi-libffi: Fix building on ARM hardware.
* gnu/packages/lisp-xyz.scm (sbcl-cffi-libffi-bootstrap)[arguments]: Add phase to adapt code to changes in libffi.
-rw-r--r--gnu/packages/lisp-xyz.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index d95da9c1cc..dfc5a2ad00 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2016, 2017 Nikita <[email protected]>
;;; Copyright © 2016, 2017 Andy Patterson <[email protected]>
;;; Copyright © 2017, 2019, 2020 Ricardo Wurmus <[email protected]>
-;;; Copyright © 2017, 2018, 2019 Efraim Flashner <[email protected]>
+;;; Copyright © 2017, 2018, 2019, 2020 Efraim Flashner <[email protected]>
;;; Copyright © 2017, 2019 Tobias Geerinckx-Rice <[email protected]>
;;; Copyright © 2018 Benjamin Slade <[email protected]>
;;; Copyright © 2018 Alex Vong <[email protected]>
@@ -2540,6 +2540,12 @@ non-consing thread safe queues and fibonacci priority queues.")
(arguments
'(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'fix-arm-support
+ (lambda _
+ ;; This is apparently deprecated since libffi-3.3.
+ (substitute* "libffi/libffi-types.lisp"
+ (("\\\(\\\(:unix64.*") ")\n"))
+ #t))
(add-after 'unpack 'fix-paths
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "libffi/libffi.lisp"