summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author宋文武 <[email protected]>2024-12-31 13:44:50 +0800
committer宋文武 <[email protected]>2025-01-01 10:48:34 +0800
commit9e812075626d0e54c7e00e8e5b19cde6944aaf05 (patch)
tree4e69568b8783d658de9a1ef92bf42970c99b2ebe
parent1b28cba79265cd5f98f78f8a41f7249d375328be (diff)
gnu: xfce4-diskperf-plugin: Update to 2.7.1.
* gnu/packages/xfce.scm (xfce4-diskperf-plugin): Update to 2.7.1. [source]: Switch to git-fetch. [native-inputs]: Add xfce4-dev-tools. [home-page]: Set to docs.xfce.org. Change-Id: If4e178843b0f2a41c13e2f94971dd3d09a62a3a2
-rw-r--r--gnu/packages/xfce.scm28
1 files changed, 14 insertions, 14 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 92265a9598..be852f1157 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -1817,24 +1817,24 @@ governor and frequencies supported and used by your system.")
(define-public xfce4-diskperf-plugin
(package
- (name "xfce4-diskperf-plugin")
- (version "2.7.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://archive.xfce.org/src/panel-plugins/"
- "xfce4-diskperf-plugin/"
- (version-major+minor version)
- "/xfce4-diskperf-plugin-" version ".tar.bz2"))
- (sha256
- (base32
- "1jgcdwiaqs06l729vbj3kgv67iwimjp8gfy7ydzlvbx6859sc2ar"))))
+ (name "xfce4-diskperf-plugin")
+ (version "2.7.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append "https://gitlab.xfce.org/panel-plugins/"
+ name))
+ (commit (string-append name "-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0fav30y6r08yyrrm0yzi9jrn6af6hw8qk7wk7pd172ajqgcyp4ai"))))
(build-system gnu-build-system)
(native-inputs
- (list intltool pkg-config))
+ (list xfce4-dev-tools))
(inputs
(list libxfce4ui xfce4-panel))
- (home-page
- "https://goodies.xfce.org/projects/panel-plugins/xfce4-diskperf-plugin")
+ (home-page "https://docs.xfce.org/panel-plugins/xfce4-diskperf-plugin/")
(synopsis "Display disk performance in the Xfce panel")
(description "This Xfce panel plugin displays instant disk/partition
performance (bytes transferred per second).")