summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <[email protected]>2025-02-09 01:52:27 +0000
committerAndreas Enge <[email protected]>2025-02-10 14:27:57 +0100
commit91d27eafc2ddac3711bc30e28e734e0afb2f7d0e (patch)
treea5b256310acc42bc705dece9637024c6322b8c66
parent58dce798cb43a6fdec48f9e5bf6045a7193cf125 (diff)
gnu: Add python-pysingular.
* gnu/packages/algebra.scm (python-pysingular): New variable. Change-Id: I57e828bd4eb2c64b2ba094ed0c9cb516fee1c5b4 Signed-off-by: Andreas Enge <[email protected]>
-rw-r--r--gnu/packages/algebra.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 68f6684254..6575af8f32 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -642,6 +642,28 @@ geometry and singularity theory.")
(license license:gpl3)
(home-page "https://www.singular.uni-kl.de/index.php")))
+(define-public python-pysingular
+ (package
+ (name "python-pysingular")
+ (version "0.9.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "PySingular" version))
+ (sha256
+ (base32 "037n3s1l08g75k22saki6813wi3ciiq45zxca11izilgagbx20ya"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:tests? #f)) ; there are no tests
+ (native-inputs (list python-setuptools python-wheel))
+ ;; XXX: GMP failed to be loaded from Singular. Pass it here for now.
+ (inputs (list gmp singular))
+ (home-page "https://github.com/sebasguts/PySingular")
+ (synopsis "Simple interface to Singular")
+ (description "This package provides a simple Python interface to the
+Singular computer algebra system.")
+ (license license:gpl2+)))
+
(define-public gmp-ecm
(package
(name "gmp-ecm")