summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAshvith Shetty <[email protected]>2024-12-02 13:40:20 +0530
committerHilton Chain <[email protected]>2024-12-31 18:50:45 +0800
commit8e80700b06e125157598b8d741234716ea13ef52 (patch)
tree133c8eb44cfe0bd3b1c0d6dcdb1c855f5a471847
parent85925fcc757f2eda2429b63f5570c759b979ebd4 (diff)
gnu: Add waylock.
* gnu/packages/zig-xyz.scm (waylock): New variable. Modified-by: Hilton Chain <[email protected]> Signed-off-by: Hilton Chain <[email protected]> Change-Id: I8a9e83ead3b2cb13471d8e92eb6e3463a646dad8
-rw-r--r--gnu/packages/zig-xyz.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/zig-xyz.scm b/gnu/packages/zig-xyz.scm
index 6881461fdf..a9ad1abde5 100644
--- a/gnu/packages/zig-xyz.scm
+++ b/gnu/packages/zig-xyz.scm
@@ -29,6 +29,7 @@
#:use-module (gnu packages)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages man)
+ #:use-module (gnu packages linux)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages wm)
@@ -109,6 +110,37 @@ mission-critical safety and performance for financial services.")
(home-page "https://github.com/tigerbeetledb/tigerbeetle")
(license license:asl2.0)))
+(define-public waylock
+ (package
+ (name "waylock")
+ (version "1.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/ifreund/waylock")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0jlq23cb5069sa5ipshhj82a9rn30frflwi9skp2kplqpxm15wwd"))))
+ (build-system zig-build-system)
+ (arguments
+ (list
+ #:install-source? #f
+ ;; No tests.
+ #:tests? #f
+ #:zig-release-type "safe"
+ #:zig-build-flags
+ #~(list "-Dpie")))
+ (inputs (list linux-pam zig-wayland zig-xkbcommon))
+ (native-inputs (list pkg-config scdoc))
+ (home-page "https://codeberg.org/ifreund/waylock")
+ (synopsis "Wayland screen locker")
+ (description
+ "Waylock is a small screen locker for Wayland compositors implementing the
+@code{ext-session-lock-v1} protocol.")
+ (license license:expat)))
+
(define-public zig-pixman
(package
(name "zig-pixman")