summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Elsing <[email protected]>2025-01-22 18:32:19 +0000
committerLudovic Courtès <[email protected]>2025-01-27 14:42:40 +0100
commit8e79dff65bdb27c15a0ab49428bcbdd1d4bf7604 (patch)
tree376c07eeb4e2b1b0c8e6cd968b93c867c092e020
parentc8ceb0cb8351adcb87c23b5c87b5e8725a94dc4e (diff)
gnu: python-sympy: Update to 1.13.3.
* gnu/packages/python-xyz.scm (python-sympy): Update to 1.13.3. [build-system]: Switch to pyproject-build-system. [arguments]<#:phases>: Adjust 'check phase. [native-inputs]: New field to add python-hypothesis, python-pytest, python-setuptools and python-wheel. Signed-off-by: Ludovic Courtès <[email protected]>
-rw-r--r--gnu/packages/python-xyz.scm24
1 files changed, 14 insertions, 10 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 29ebcec153..31a5166574 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15034,24 +15034,28 @@ syllables in a word.")
(define-public python-sympy
(package
(name "python-sympy")
- (version "1.11.1")
+ (version "1.13.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "sympy" version))
(sha256
- (base32 "0n46x1rfy8c2a9za3yp2va5icigxj805f9fmiq8c1drwwvf808z3"))))
- (build-system python-build-system)
+ (base32 "1nf4zrjjbnv47n6sl6x9blfyarski61vdjaz4ygb62hfag3d4zxj"))))
+ (build-system pyproject-build-system)
(arguments
- `(#:phases
+ '(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda* (#:key outputs #:allow-other-keys)
- (invoke
- (or (which "python3") (which "python"))
- "-c" "import sympy; sympy.test(\"/core\")"))))))
- (propagated-inputs
- (list python-mpmath))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (if tests?
+ (invoke "python3" "-c"
+ "import sympy; sympy.test(\"/core\")")))))))
+ (propagated-inputs (list python-mpmath))
+ (native-inputs
+ (list python-hypothesis
+ python-pytest
+ python-setuptools
+ python-wheel))
(home-page "https://www.sympy.org/")
(synopsis "Python library for symbolic mathematics")
(description