summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2025-01-04 21:31:45 +0100
committerRicardo Wurmus <[email protected]>2025-01-20 21:37:36 +0100
commit8c495458a777afce67d097bf3d1aa8815899f099 (patch)
treed4405a2c87fc6817870995395b96a1c9f32b3d2e
parent52aafe952249bf086efa359c0a6c0288f0ab07ef (diff)
gnu: python-fastapi: Relax requirements.
* gnu/packages/python-web.scm (python-fastapi)[arguments]: Add phase 'relax-requirements. Change-Id: I639d894eb1ee207cddcaa52344e48291c7a2a5c9
-rw-r--r--gnu/packages/python-web.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index b8b1d33b26..fad7eed49e 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -9870,7 +9870,13 @@ and FastAPI.")
;; it.
"--ignore=tests/test_multipart_installation.py"
;; FIXME: Unclear why these 8 tests fail.
- "--ignore=tests/test_dependency_contextmanager.py")))
+ "--ignore=tests/test_dependency_contextmanager.py")
+ #:phases
+ '(modify-phases %standard-phases
+ (add-after 'unpack 'relax-requirements
+ (lambda _
+ (substitute* "pyproject.toml"
+ (("<0.42.0") "<=0.42.0")))))))
(propagated-inputs (list python-email-validator
python-fastapi-cli
python-httpx