summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <[email protected]>2025-02-19 20:40:16 +0200
committerEfraim Flashner <[email protected]>2025-02-19 22:33:47 +0200
commit83f6e1b59f138d4deea048d41d4d870980eaa215 (patch)
treedbd4a4eaf5361f986eb2d48570087d551564fc03
parent71707fa1e1889e62d9942d0760c33fef8d895439 (diff)
gnu: snac2: Update to 2.72.
* gnu/packages/fediverse.scm (snac2): Update to 2.72. [arguments]: Remove custom 'remove-usr-local phase. Change-Id: I7ed829aec7c8b3f24095401def15a738eba25486
-rw-r--r--gnu/packages/fediverse.scm15
1 files changed, 4 insertions, 11 deletions
diff --git a/gnu/packages/fediverse.scm b/gnu/packages/fediverse.scm
index b1d03a3802..c660483b56 100644
--- a/gnu/packages/fediverse.scm
+++ b/gnu/packages/fediverse.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2019-2024 Efraim Flashner <[email protected]>
+;;; Copyright © 2019-2025 Efraim Flashner <[email protected]>
;;; Copyright © 2019 Tobias Geerinckx-Rice <[email protected]>
;;; Copyright © 2021 Taiju HIGASHI <[email protected]>
;;; Copyright © 2024 Sergio Durigan Junior <[email protected]>
@@ -203,7 +203,7 @@ seamlessly with your desktop environment.")
(define-public snac2
(package
(name "snac")
- (version "2.68")
+ (version "2.72")
(source
(origin
(method git-fetch)
@@ -212,20 +212,13 @@ seamlessly with your desktop environment.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1sdhwc88yhqgij88js957p86wmq9j0rscski4flympcrg3qk43f9"))))
+ (base32 "1ykrqyx0jc2cmjnj8ygqix2n64bfa2q444qz9ccsnxr3717mn1xc"))))
(build-system gnu-build-system)
(inputs (list curl openssl))
(arguments
(list
#:phases #~(modify-phases %standard-phases
- (delete 'configure)
- (add-after 'unpack 'remove-usr-local
- (lambda _
- (substitute* "Makefile"
- (("-I/usr/local/include")
- "")
- (("-L/usr/local/lib")
- "")))))
+ (delete 'configure))
#:tests? #f ; no test target
#:make-flags #~(list (string-append "CC=" #$(cc-for-target))
(string-append "CFLAGS=-O2 -g -Wall -Wextra")