summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2025-01-06 21:02:43 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2025-01-21 23:47:40 +0000
commit82ec069b4f67880d1c2fec7a7814f37255d1192c (patch)
tree5a762b10de2f5d12fb2fc34f195f5d72e3494a59
parent6a6052c752fe425e2411ea529322f36422c0de5d (diff)
gnu: go-github-com-docker-go-units: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-docker-go-units): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: Ife0e8e396188645b60527e94137693e29f0a4eb0
-rw-r--r--gnu/packages/golang-xyz.scm24
-rw-r--r--gnu/packages/golang.scm22
2 files changed, 24 insertions, 22 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 55fbcb1d7b..e268c9501f 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -3717,6 +3717,30 @@ GNU extensions to the POSIX recommendations for command-line options}. This
is an activly maintained fork of @url{https://github.com/ogier/pflag}.")
(license license:bsd-3)))
+(define-public go-github-com-docker-go-units
+ (package
+ (name "go-github-com-docker-go-units")
+ (version "0.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/docker/go-units")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0q92l7pyfg9rn4ljr1warnv1ri6z7svah7m3rqmvmyaw6bzdbbw8"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/docker/go-units"))
+ (home-page "https://github.com/docker/go-units")
+ (synopsis "Parse and print size and time units in human-readable format")
+ (description
+ "@code{go-units} is a library to transform human friendly measurements
+into machine friendly values.")
+ (license license:asl2.0)))
+
(define-public go-github-com-docopt-docopt-go
(let ((commit "ee0de3bc6815ee19d4a46c7eb90f829db0e014b1")
(revision "0"))
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index aaf35b1681..643c511b0c 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2591,28 +2591,6 @@ Go language. In particular it provides tools to deal with network address
translation (NAT), proxies, sockets, and transport layer security (TLS).")
(license license:asl2.0)))
-(define-public go-github-com-docker-go-units
- (package
- (name "go-github-com-docker-go-units")
- (version "0.5.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/docker/go-units")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0q92l7pyfg9rn4ljr1warnv1ri6z7svah7m3rqmvmyaw6bzdbbw8"))))
- (build-system go-build-system)
- (arguments '(#:import-path "github.com/docker/go-units"))
- (home-page "https://github.com/docker/go-units")
- (synopsis "Parse and print size and time units in human-readable format")
- (description
- "@code{go-units} is a library to transform human friendly measurements into
-machine friendly values.")
- (license license:asl2.0)))
-
(define-public go-github-com-aarzilli-golua
(let ((commit "03fc4642d792b1f2bc5e7343b403cf490f8c501d")
(revision "0"))