summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLiliana Marie Prikler <[email protected]>2024-11-23 08:59:46 +0100
committerLiliana Marie Prikler <[email protected]>2025-03-02 20:31:36 +0100
commit82de874b1eaa1e101d52e428373aa2826ce2d59c (patch)
tree3859d560a0979b9fa1853f5b1e61e8383dda7c18
parent11d07a4984a9fea681d47bb5119b2aee4ccb0bcd (diff)
gnu: modem-manager: Fix build.
* gnu/packages/patches/modem-manager-fix-test-wrapper.patch: New file. * gnu/packages/freedesktop.scm (modem-manager)[patches]: Use it here. * gnu/local.mk (dist_patch_DATA): Register it here.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/freedesktop.scm1
-rw-r--r--gnu/packages/patches/modem-manager-fix-test-wrapper.patch37
3 files changed, 39 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index a622a6a81e..c6534d27df 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1858,6 +1858,7 @@ dist_patch_DATA = \
%D%/packages/patches/mpg321-CVE-2019-14247.patch \
%D%/packages/patches/mpg321-gcc-10.patch \
%D%/packages/patches/modglue-fix-build.patch \
+ %D%/packages/patches/modem-manager-fix-test-wrapper.patch \
%D%/packages/patches/module-init-tools-moduledir.patch \
%D%/packages/patches/monero-use-system-miniupnpc.patch \
%D%/packages/patches/mono-1.2.6-bootstrap.patch \
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 76507486fc..3783d4335c 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -2149,6 +2149,7 @@ which speak the Qualcomm MSM Interface (QMI) protocol.")
(git-reference
(url "https://gitlab.freedesktop.org/mobile-broadband/ModemManager")
(commit version)))
+ (patches (search-patches "modem-manager-fix-test-wrapper.patch"))
(file-name (git-file-name name version))
(sha256
(base32
diff --git a/gnu/packages/patches/modem-manager-fix-test-wrapper.patch b/gnu/packages/patches/modem-manager-fix-test-wrapper.patch
new file mode 100644
index 0000000000..b18386dcc7
--- /dev/null
+++ b/gnu/packages/patches/modem-manager-fix-test-wrapper.patch
@@ -0,0 +1,37 @@
+From daa829287894273879799a383ed4dc373c6111b0 Mon Sep 17 00:00:00 2001
+From: Alyssa Ross <[email protected]>
+Date: Wed, 8 May 2024 09:49:59 +0200
+Subject: [PATCH] build: prepend to LD_LIBRARY_PATH and GI_TYPELIB_PATH
+
+In Nixpkgs packages are installed in separate prefixes.
+Starting from GLib / gobject-introspection 2.80, GLib introspection data
+is provided by GLib itself instead of gobject-introspection. This causes
+tests failures in Nixpkgs because the GI_TYPELIB_PATH set by the build
+environment was overridden, leaving it unable to find GLib:
+
+ ImportError: cannot import name GLib, introspection typelib not found
+
+Only GI_TYPELIB_PATH needs to be preserved in our case, but I've made
+the same change for LD_LIBRARY_PATH, other environments might rely on
+that in a similar way.
+---
+ tools/tests/test-wrapper.sh.in | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/tools/tests/test-wrapper.sh.in b/tools/tests/test-wrapper.sh.in
+index fb8cd5e8d5..d6484bed60 100755
+--- a/tools/tests/test-wrapper.sh.in
++++ b/tools/tests/test-wrapper.sh.in
+@@ -1,5 +1,8 @@
+ #!/bin/sh
+
++export LD_LIBRARY_PATH=@abs_top_builddir@/libmm-glib"${LD_LIBRARY_PATH+:$LD_LIBRARY_PATH}"
++export GI_TYPELIB_PATH=@abs_top_builddir@/libmm-glib"${GI_TYPELIB_PATH+:$GI_TYPELIB_PATH}"
++
+ # For debugging behavior of test-modemmanager-service.py, you can modify
+ # this line to add --log-file option
+-LD_LIBRARY_PATH=@abs_top_builddir@/libmm-glib GI_TYPELIB_PATH=@abs_top_builddir@/libmm-glib @abs_top_srcdir@/tools/test-modemmanager-service.py
++exec @abs_top_srcdir@/tools/test-modemmanager-service.py
+--
+GitLab
+