summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <[email protected]>2020-03-04 21:13:55 +0200
committerEfraim Flashner <[email protected]>2020-03-15 08:54:31 +0200
commit6e003bd4ccd7470247b1fdbee3a6c6a0ad8054ac (patch)
tree8f2dec1ea489c8a3282e742e0641fb5cba930625
parent3eca7ff9681b68d19016737dacc0d7a0572af3e6 (diff)
gnu: Add python-pytest-vcr.
* gnu/packages/python-check.scm (python-pytest-vcr): New variable.
-rw-r--r--gnu/packages/python-check.scm34
1 files changed, 33 insertions, 1 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index a69619b96a..70a5b1e452 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2019 Ricardo Wurmus <[email protected]>
;;; Copyright © 2019 Tobias Geerinckx-Rice <[email protected]>
-;;; Copyright © 2019 Efraim Flashner <[email protected]>
+;;; Copyright © 2019, 2020 Efraim Flashner <[email protected]>
;;; Copyright © 2019 Maxim Cournoyer <[email protected]>
;;; Copyright © 2019 Hartmut Goebel <[email protected]>
;;; Copyright © 2020 Julien Lepiller <[email protected]>
@@ -30,6 +30,7 @@
#:use-module (guix utils)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
+ #:use-module (guix git-download)
#:use-module (guix download)
#:use-module (guix build-system python))
@@ -109,6 +110,37 @@ detect the absence of a cassette file and once again record all HTTP
interactions, which will update them to correspond to the new API.")
(license license:expat)))
+(define-public python-pytest-vcr
+ (package
+ (name "python-pytest-vcr")
+ (version "1.0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ktosiek/pytest-vcr")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1i6fin91mklvbi8jzfiswvwf1m91f43smpj36a17xrzk4gisfs6i"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest" "tests/"))))))
+ (propagated-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-vcrpy" ,python-vcrpy)))
+ (home-page "https://github.com/ktosiek/pytest-vcr")
+ (synopsis "Plugin for managing VCR.py cassettes")
+ (description
+ "Plugin for managing VCR.py cassettes.")
+ (license license:expat)))
+
(define-public python-pytest-checkdocs
(package
(name "python-pytest-checkdocs")