summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEvgeny Pisemsky <[email protected]>2025-01-27 23:29:13 +0300
committer宋文武 <[email protected]>2025-02-02 14:25:28 +0800
commit66ee8de7522be7b47a74eaf0e199298049efb749 (patch)
treecb9329bc96a16c7a0fc0f2488b304a0536535f65
parentdf909321b659ccac6afd84a25430a4d600ffea40 (diff)
gnu: Add python-securetar.
* gnu/packages/python-xyz.scm (python-securetar): New variable. Change-Id: Ic27644f20f59b6dceb2c15c637eb2db5955abba3 Signed-off-by: 宋文武 <[email protected]>
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ff0fda3300..d042717f15 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -21707,6 +21707,29 @@ GnuPG encryption, and more. It also supports management of Amazon's
CloudFront content delivery network.")
(license license:gpl2+)))
+(define-public python-securetar
+ (package
+ (name "python-securetar")
+ (version "2025.1.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pvizeli/securetar")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1b9m29j4mjiv7925wrbiyj6vyx7m9qmdz40zqd4vgxhz4pq6x3xw"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-setuptools python-wheel python-pytest))
+ (propagated-inputs (list python-cryptography))
+ (home-page "https://github.com/pvizeli/securetar")
+ (synopsis "Python module to handle tarfile backups")
+ (description
+ "This library provides a streaming wrapper around python tarfile and allow
+secure handling files and support encryption.")
+ (license license:asl2.0)))
+
(define-public python-pkgconfig
(package
(name "python-pkgconfig")