summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <[email protected]>2025-02-02 01:38:52 +0100
committerDanny Milosavljevic <[email protected]>2025-02-02 01:38:52 +0100
commit634d534a464da49a9621938ceccec48fee59831d (patch)
tree65eb57a06c3937a37af6771db698e276361565fb
parent20599e56a6f66cad60bec81f8e626cc553930733 (diff)
gnu: Add go-github-com-arbovm-levenshtein.
* gnu/packages/golang-xyz.scm (go-github-com-arbovm-levenshtein): New variable. Change-Id: Ibcee5d42b8d2c333ec38bc7405611091ec6e7887
-rw-r--r--gnu/packages/golang-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 818a44518f..7281738e30 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -17760,6 +17760,30 @@ contain equivalent code.")
@@url{https://en.wikipedia.org/wiki/ISO_8601#Durations,ISO 8601 durations} and
converting them to the often much more useful @@code{time.Duration}.")
(license license:expat)))
+
+(define-public go-github-com-arbovm-levenshtein
+ (package
+ (name "go-github-com-arbovm-levenshtein")
+ (version "0.0.0-20160628152529-48b4e1c0c4d0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/arbovm/levenshtein")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0nmx2iip8xpnbmy6gvqpc9ikizr33dr40xgv746h0b0by8n7rv7y"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/arbovm/levenshtein"))
+ (home-page "https://github.com/arbovm/levenshtein")
+ (synopsis "Levenshtein Distance")
+ (description
+ "This package provides a way to calculate the
+@url{http://en.wikipedia.org/wiki/Levenshtein_distance,Levenshtein Distance}.")
+ (license license:bsd-3)))
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar