summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2025-01-03 21:35:18 +0100
committerRicardo Wurmus <[email protected]>2025-01-20 21:37:34 +0100
commit556690a139806fd26a5a1e242bbc53f7e1cbc962 (patch)
tree39363b540a7b2d5b5b8fcf78aec5d48c3bb2b6e9
parent76f212716ba2d092707c7f5642b0067a7ffff9f2 (diff)
gnu: Add python-rich-toolkit.
* gnu/packages/python-xyz.scm (python-rich-toolkit): New variable. Change-Id: I1a5f0d9e8241fef0396aaed534b373d2670c48ad
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 594c7bd019..b701336d23 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2893,6 +2893,25 @@ with Numpy and SciPy.")
human-prettifier based on the @code{rich} Python library.")
(license license:expat)))
+(define-public python-rich-toolkit
+ (package
+ (name "python-rich-toolkit")
+ (version "0.12.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "rich_toolkit" version))
+ (sha256
+ (base32 "0h3cda068xc0v8jqcp7fyrb6d4xlhcjlxm5bfygk04408500pjzs"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-click python-rich python-typing-extensions))
+ (native-inputs (list python-hatchling python-inline-snapshot python-pytest))
+ (home-page "https://pypi.org/project/rich-toolkit/")
+ (synopsis "Rich toolkit for building command-line applications")
+ (description "This package provides the Rich toolkit for building
+command-line applications.")
+ (license license:expat)))
+
(define-public python-shapely
(package
(name "python-shapely")