summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2025-01-17 22:18:05 +0100
committerRicardo Wurmus <[email protected]>2025-01-20 21:38:03 +0100
commit4ea986c35c8458450cb8e83f81c087dadb79efbf (patch)
tree02496b8d699946b1525e9d9cb190865a895e3cf8
parentd8c294e8800aa07b3570f07dfb65872e4e539587 (diff)
gnu: python-modin: Update to 0.32.0.
* gnu/packages/python-science.scm (python-modin): Update to 0.32.0. [build-system]: Use pyproject-build-system. [arguments]: Remove phase 'make-files-writable; disable one test; update custom 'check phase. [propagated-inputs]: Add python-s3fs. [native-inputs]: Add python-boto3 and python-wheel. Change-Id: I1d74013902e3387945586192b88c1e4fd8256733
-rw-r--r--gnu/packages/python-science.scm39
1 files changed, 21 insertions, 18 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 0bc22444ea..691db116e3 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -2879,7 +2879,7 @@ computing in Python. It extends both the @code{concurrent.futures} and
(define-public python-modin
(package
(name "python-modin")
- (version "0.15.1")
+ (version "0.32.0")
(source
(origin
;; The archive on pypi does not include all required files.
@@ -2890,38 +2890,40 @@ computing in Python. It extends both the @code{concurrent.futures} and
(file-name (git-file-name name version))
(sha256
(base32
- "0nf2pdqna2vn7vq7q7b51f3cfbrxfn77pyif3clibjsxzvfm9k03"))))
- (build-system python-build-system)
+ "1vb3iffgspryb6nvwiwdnypb922vkn2yvyzc1y0wwxcb0c0fl78d"))))
+ (build-system pyproject-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'make-files-writable
- (lambda _
- (for-each make-file-writable (find-files "."))))
+ (list
+ #:test-flags
+ ;; These four tests fail because an expected error is not raised.
+ '(list "-k" "not test_binary_bad_broadcast")
+ #:phases
+ '(modify-phases %standard-phases
(add-after 'unpack 'loosen-requirements
(lambda _
(substitute* "setup.py"
;; Don't depend on a specific version of Pandas.
- (("pandas==")
- "pandas>="))))
+ (("pandas==") "pandas>="))))
(replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
+ (lambda* (#:key tests? test-flags #:allow-other-keys)
(when tests?
(setenv "MODIN_ENGINE" "dask")
- (invoke "python" "-m" "pytest"
- "modin/pandas/test/test_concat.py")
+ (apply invoke "python" "-m" "pytest"
+ "modin/tests/numpy" test-flags)
(setenv "MODIN_ENGINE" "python")
- (invoke "python" "-m" "pytest"
- "modin/pandas/test/test_concat.py")))))))
+ (apply invoke "python" "-m" "pytest"
+ "modin/tests/numpy" test-flags)))))))
(propagated-inputs
(list python-cloudpickle
python-dask
python-distributed
python-numpy
python-packaging
- python-pandas))
+ python-pandas
+ python-s3fs))
(native-inputs
- (list python-coverage
+ (list python-boto3
+ python-coverage
python-jinja2
python-lxml
python-matplotlib
@@ -2938,7 +2940,8 @@ computing in Python. It extends both the @code{concurrent.futures} and
python-tables
python-tqdm
python-xarray
- python-xlrd))
+ python-xlrd
+ python-wheel))
(home-page "https://github.com/modin-project/modin")
(synopsis "Make your pandas code run faster")
(description