summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-24 12:51:55 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:42:21 +0000
commit44a48160dd11f736071f075a9528530e265c936b (patch)
tree250042957cc9c56f86d3cac92bf2b7819e09c631
parent57b3410ca3f5ee0842f9b87f6a6ab4ab42268886 (diff)
gnu: go-howett-net-plist: Fix tests.
* gnu/packages/golang.scm (go-howett-net-plist) [arguments] <test-subdirs>: Skip tests in cmd. Change-Id: I5d1da9b029ff6a72fa9c725d0de18d17c8d358a7
-rw-r--r--gnu/packages/golang.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index e97a54266e..2970455da3 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1608,7 +1608,9 @@ retry strategies, such as fixed delay, backoff delay, and random delay.")
(build-system go-build-system)
(arguments
(list
- #:import-path "howett.net/plist"))
+ #:import-path "howett.net/plist"
+ ;; cmd requires gopkg.in/yaml.v1
+ #:test-subdirs #~(list "internal/..." ".")))
(propagated-inputs
(list go-github-com-jessevdk-go-flags
go-gopkg-in-check-v1))