summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <[email protected]>2025-02-02 01:20:34 +0100
committerDanny Milosavljevic <[email protected]>2025-02-02 01:20:34 +0100
commit336d31b692bce1245acdee5644cc89e26648cbb6 (patch)
tree3d4ae6ac7252cd044c48ed7e386146e52393c4a9
parent6c70b77c353d6a5e8254842e1b973e7924ee4c21 (diff)
gnu: Add go-github-com-go-viper-mapstructure-v2.
* gnu/packages/golang-xyz.scm (go-github-com-go-viper-mapstructure-v2): New variable. Change-Id: I70f70a5bd392264701fe05a5f17fe2d20b53916f
-rw-r--r--gnu/packages/golang-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index bfba9d0273..91b225a5a6 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -17686,6 +17686,31 @@ editor.")
#:import-path "github.com/client9/misspell/cmd/misspell"
#:unpack-path "github.com/client9/misspell"))))
+(define-public go-github-com-go-viper-mapstructure-v2
+ (package
+ (name "go-github-com-go-viper-mapstructure-v2")
+ (version "2.2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/go-viper/mapstructure")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1x13x2s0vkikmn5wcarxskhr6c90s64nkbsgjsh7g9sh4v31n5yw"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/go-viper/mapstructure/v2"
+ #:unpack-path "github.com/go-viper/mapstructure/v2"))
+ (home-page "https://github.com/go-viper/mapstructure")
+ (synopsis "Go type converters")
+ (description
+ "Package mapstructure exposes functionality to convert one arbitrary Go type into
+another, typically to convert a map[string]interface{} into a native Go
+structure.")
+ (license license:expat)))
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar