summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2021-04-20 16:34:43 +0200
committerRicardo Wurmus <[email protected]>2021-04-20 16:40:10 +0200
commit2be32ecc7479bc714395e13380462c7a0928881a (patch)
tree9e0dbe391c57b638588753cbd08eac2bed8ec97a
parent3313f61e18cbb4a89ec6c980b39f8e5fcad2b890 (diff)
gnu: Add nanodbc.
* gnu/packages/databases.scm (nanodbc): New variable.
-rw-r--r--gnu/packages/databases.scm31
1 files changed, 30 insertions, 1 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index b23ef04d36..2353e3b731 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -28,7 +28,7 @@
;;; Copyright © 2017, 2018 Ben Woodcroft <[email protected]>
;;; Copyright © 2017 Rutger Helling <[email protected]>
;;; Copyright © 2017, 2018 Pierre Langlois <[email protected]>
-;;; Copyright © 2015, 2017, 2018, 2019 Ricardo Wurmus <[email protected]>
+;;; Copyright © 2015, 2017, 2018, 2019, 2021 Ricardo Wurmus <[email protected]>
;;; Copyright © 2017 Kristofer Buffington <[email protected]>
;;; Copyright © 2018 Amirouche Boubekki <[email protected]>
;;; Copyright © 2018 Joshua Sierles, Nextjournal <[email protected]>
@@ -2073,6 +2073,35 @@ Driver.")
;; COPYING contains copy of lgpl2.1 - but copyright notices just say "LGPL"
(home-page "http://www.unixodbc.org")))
+(define-public nanodbc
+ (package
+ (name "nanodbc")
+ (version "2.13.0")
+ (source (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/nanodbc/nanodbc")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1q80p7yv9mcl4hyvnvcjdr70y8nc940ypf368lp97vpqn5yckkgm"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags
+ ;; The tests require ODBC backends to be installed.
+ (list "-DNANODBC_DISABLE_TESTS=ON")
+ #:tests? #false))
+ (inputs
+ `(("unixodbc" ,unixodbc)))
+ (home-page "https://nanodbc.io/")
+ (synopsis "C++ wrapper for the native C ODBC API")
+ (description "The goal for nanodbc is to make developers happy by providing
+a simpler and less verbose API for working with ODBC. Common tasks should be
+easy, requiring concise and simple code.")
+ (license license:expat)))
+
(define-public unqlite
(package
(name "unqlite")