summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2015-01-30 10:47:23 +0100
committerRicardo Wurmus <[email protected]>2015-01-30 17:08:19 +0100
commit2b0bba49e19f560ed1de3634d28ee13532dcb823 (patch)
treec9fa0969d7daca433ee6d740ee9881e48d43f678
parent582100a0c07a245abd1580e9caaf9896e0d0e67f (diff)
gnu: Add jansson.
* gnu/packages/web.scm (jansson): New variable.
-rw-r--r--gnu/packages/web.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 554f2a3ae4..7abed9d84a 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2013 Aljosha Papsch <[email protected]>
;;; Copyright © 2014, 2015 Ludovic Courtès <[email protected]>
;;; Copyright © 2014 Mark H Weaver <[email protected]>
+;;; Copyright © 2015 Ricardo Wurmus <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -142,6 +143,26 @@ and as a proxy to reduce the load on back-end HTTP or mail servers.")
;; except for two source files which are bsd-4 licensed.
(license (list l:bsd-2 l:expat l:bsd-3 l:bsd-4))))
+(define-public jansson
+ (package
+ (name "jansson")
+ (version "2.7")
+ (source (origin
+ (method url-fetch)
+ (uri
+ (string-append "http://www.digip.org/jansson/releases/jansson-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1mvq9p85khsl818i4vbszyfab0fd45mdrwrxjkzw05mk1xcyc1br"))))
+ (build-system gnu-build-system)
+ (home-page "http://www.digip.org/jansson/")
+ (synopsis "JSON C library")
+ (description
+ "Jansson is a C library for encoding, decoding and manipulating JSON
+data.")
+ (license l:expat)))
+
(define-public json-c
(package
(name "json-c")