summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author宋文武 <[email protected]>2024-12-31 13:05:31 +0800
committer宋文武 <[email protected]>2025-01-01 10:48:34 +0800
commit2898017e5125a21621ce0761c44d5e71ba6f1fcf (patch)
tree3f35d6d96a3c182506f11b523699178cc96a80bb
parentbcb94c743e92e971a10854cc1ae15f6b80a4770b (diff)
gnu: xfburn: Switch to git source.
* gnu/packages/xfce.scm (xfburn)[source]: Switch to git-fetch. [arguments]: Add "--enable-maintainer-mode" to configure-flags. [native-inputs]: Add docbook-xsl, libxslt and xfce4-dev-tools. [home-page]: Set to docs.xfce.org. Change-Id: I861899747b17427b532923a769240ce49979f16c
-rw-r--r--gnu/packages/xfce.scm24
1 files changed, 14 insertions, 10 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index d064299812..0a9539a71d 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -1513,17 +1513,21 @@ sending standard messages over D-Bus using the
(package
(name "xfburn")
(version "0.7.2")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://archive.xfce.org/src/apps/xfburn/"
- (version-major+minor version) "/"
- "xfburn-" version ".tar.bz2"))
- (sha256
- (base32
- "09crg8vd6vs671lbbhy1ch9hf3d3xvfynh6vj5zlhpikyzch3fy2"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append "https://gitlab.xfce.org/apps/" name))
+ (commit (string-append name "-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "18i25n81qzgb77w5vc6n4hwnw893204az8c1bg5k9229sz28r7vq"))))
(build-system gnu-build-system)
+ (arguments
+ (list #:configure-flags
+ #~(list "--enable-maintainer-mode"))) ;for xfburn.1
(native-inputs
- (list intltool pkg-config))
+ (list docbook-xsl libxslt xfce4-dev-tools))
(inputs
(list exo
gstreamer
@@ -1535,7 +1539,7 @@ sending standard messages over D-Bus using the
libburn
libisofs
libxfce4ui))
- (home-page "https://goodies.xfce.org/projects/applications/xfburn")
+ (home-page "https://docs.xfce.org/apps/xfburn/")
(synopsis "GTK+ based CD, DVD and Blu-ray burning application")
(description
"Xfburn is a simple CD, DVD, and Blu-ray burning tool based on