summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author宋文武 <[email protected]>2024-12-31 13:13:58 +0800
committer宋文武 <[email protected]>2025-01-01 10:48:34 +0800
commit255404fce79e214576690b97d236716ae042756c (patch)
tree23b09e60f4a23094060fc471b63329db6d5735bf
parent5084886e5c03498eb4a004b251f0b4ca69fb5ce7 (diff)
gnu: xfce4-screenshooter: Switch to git source.
* gnu/packages/xfce.scm (xfce4-screenshooter)[source]: Switch to git-fetch. [native-inputs]: Add xfce4-dev-tools. [inputs]: Add wlr-protocols. [home-page]: Set to docs.xfce.org. Change-Id: I71b58dffa442b2fb150f5023a4374410b83eebc2
-rw-r--r--gnu/packages/xfce.scm26
1 files changed, 12 insertions, 14 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index fca4ed8435..a5a1c1584a 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -1591,23 +1591,21 @@ of data to either CD/DVD/BD.")
(package
(name "xfce4-screenshooter")
(version "1.11.1")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://archive.xfce.org/src/apps/"
- "xfce4-screenshooter/"
- (version-major+minor version)
- "/xfce4-screenshooter-"
- version ".tar.bz2"))
- (sha256
- (base32
- "0kfk6x6g1y49wqs8vvhv257dwkjac9ac5g8l6bbzc9lvmhvllk6r"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append "https://gitlab.xfce.org/apps/" name))
+ (commit (string-append name "-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1wxgc84f5kgs896mjpn2sq7ikh3gpfyilpqfarmlzpmpmmhgvppw"))))
(build-system gnu-build-system)
(native-inputs
- (list pkg-config intltool
- `(,glib "bin"))) ; glib-genmarshal
+ (list xfce4-dev-tools))
(inputs
- (list exo libsoup-minimal-2 libxfce4ui xfce4-panel))
- (home-page "https://goodies.xfce.org/projects/applications/xfce4-screenshooter")
+ (list exo libsoup-minimal-2 libxfce4ui wlr-protocols xfce4-panel))
+ (home-page "https://docs.xfce.org/apps/xfce4-screenshooter/")
(synopsis "Xfce's application to take screenshots")
(description
"This application allows you to capture the entire screen, the active