summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2025-01-03 10:00:05 +0100
committerRicardo Wurmus <[email protected]>2025-01-20 21:37:32 +0100
commit23efac5783d01b158bb400503023397bc86ecb60 (patch)
tree44ac14894fd8e39f5b72da119134346d364d3589
parent29fde4e79ee282e4dc336ad49656c40e551364ba (diff)
gnu: Remove python-dataclasses.
A newer version of dataclasses is part of Python. * gnu/packages/python-xyz.scm (python-dataclasses): Remove variable. Change-Id: I0e2580aab80a7245ecb1ecbcee3a59554feeb325
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 0 insertions, 21 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index dfa4198f74..ecbb4dcc69 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -34653,27 +34653,6 @@ asyncio applications.")
@code{typing} module that are supported by the Pyre typechecker.")
(license license:expat)))
-(define-public python-dataclasses
- (package
- (name "python-dataclasses")
- (version "0.8")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "dataclasses" version))
- (sha256
- (base32
- "15sc12nrc7gxwb30vfa6frzdnpmbap9ibi1fr1yrbkra6izhcyc4"))))
- (build-system python-build-system)
- (home-page
- "https://github.com/ericvsmith/dataclasses")
- (synopsis
- "Backport of the @code{dataclasses} module for Python 3.6")
- (description
- "This is an implementation of PEP 557, Data Classes. It is a
-backport of the @code{dataclasses} module for Python 3.6.")
- (license license:asl2.0)))
-
(define-public python-pywatchman
(package
(name "python-pywatchman")