summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2024-12-31 21:13:55 +0100
committerRicardo Wurmus <[email protected]>2025-01-20 21:37:28 +0100
commit1f2f56c2ed7016f9dfeb83533f492cfcb7ebaa4d (patch)
tree956faf20b53a9e3c406ab5483ae477873aacec6a
parent8c06ed66d0dc24ea5bafa2045f609a5f76006ad5 (diff)
gnu: python-falcon: Update to 4.0.2.
* gnu/packages/python-web.scm (python-falcon): Update to 4.0.2. [source]: Remove snippet. [arguments]: Disable slow tests; rename 'set-HOME to 'pre-check. [native-inputs]: Replace python-cython with python-cython-3. Change-Id: I10d3b412b8abc3bfb2271adba7fb1597fdb24098
-rw-r--r--gnu/packages/python-web.scm30
1 files changed, 11 insertions, 19 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 66ca00def3..63addcb94f 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1430,7 +1430,7 @@ Interchange Format (SARIF)} file format.")
(define-public python-falcon
(package
(name "python-falcon")
- (version "3.1.0")
+ (version "4.0.2")
(source
(origin
;; Use git, as there are some test files missing from the PyPI release,
@@ -1440,37 +1440,29 @@ Interchange Format (SARIF)} file format.")
(url "https://github.com/falconry/falcon")
(commit version)))
(file-name (git-file-name name version))
- (modules '((guix build utils)))
- (snippet
- '(begin
- (delete-file-recursively "falcon/vendor")
- (substitute* "setup.py"
- ((".*falcon\\.vendor\\.mimeparse.*") ""))
- (substitute* '("falcon/media/handlers.py"
- "falcon/request.py"
- "tests/test_deps.py")
- (("from falcon\\.vendor ") "")
- (("mimeparse.mimeparse") "mimeparse"))))
(sha256
(base32
- "17k31d8avl63xsr6fzvmkxcsm7gnz5dqpgsz65psm1lpc38c79k3"))))
+ "1zhyvfbz4c1bxd4vbsgk19dzih6kkzgin10lmsr32x3b4qgnwqxs"))))
(build-system pyproject-build-system)
(arguments
(list
#:test-flags
- '(list "--ignore=tests/test_utils.py"
- "--ignore-glob=examples/*"
- "--ignore-glob=bench/*" "tests")
+ '(list "-k" "not slow"
+ "--ignore-glob=examples/*" "--ignore-glob=bench/*" "tests")
#:phases
'(modify-phases %standard-phases
- (add-before 'check 'set-HOME
- (lambda _ (setenv "HOME" "/tmp"))))))
+ (add-before 'check 'pre-check
+ (lambda _
+ (setenv "FALCON_ASGI_WRAP_NON_COROUTINES" "Y")
+ (setenv "FALCON_TESTING_SESSION" "Y")
+ (setenv "PYTHONASYNCIODEBUG" "1")
+ (setenv "HOME" "/tmp"))))))
(propagated-inputs
(list python-mimeparse))
(native-inputs
(list python-aiofiles
python-cbor2
- python-cython ;for faster binaries
+ python-cython-3 ;for faster binaries
python-fakeredis
python-httpx
python-mujson