summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2025-01-02 18:31:16 +0100
committerRicardo Wurmus <[email protected]>2025-01-20 21:37:31 +0100
commit1b02bdeb1a0262d4a49736507ee2e2a75390a332 (patch)
tree84fc114c85feb60e76f414dda0e9a238928c1dd7
parentd4ba0e0f77392023fede070e9ff12c5624763998 (diff)
gnu: python-pyvisa: Update to 1.14.1.
* gnu/packages/engineering.scm (python-pyvisa): Update to 1.14.1. [source]: Simplify snippet. [arguments]: Fix tests by adding --pyargs. [native-inputs]: Add python-setuptools-scm. [propagated-inputs]: Remove python-dataclasses. Change-Id: I59fc4333e975e9e5ae4a906df20dbf7bce5d6a0a
-rw-r--r--gnu/packages/engineering.scm31
1 files changed, 17 insertions, 14 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index f9c4ac9bbd..fc92f5f070 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015-2023 Ricardo Wurmus <[email protected]>
+;;; Copyright © 2015-2025 Ricardo Wurmus <[email protected]>
;;; Copyright © 2015 Federico Beffa <[email protected]>
;;; Copyright © 2016, 2018, 2020-2024 Efraim Flashner <[email protected]>
;;; Copyright © 2016 David Thompson <[email protected]>
@@ -2661,32 +2661,35 @@ specification can be downloaded at @url{http://3mf.io/specification/}.")
(define-public python-pyvisa
(package
(name "python-pyvisa")
- (version "1.13.0")
+ (version "1.14.1")
(source (origin
(method url-fetch)
(uri (pypi-uri "PyVISA" version))
(sha256
(base32
- "1iprr3h6d4w6v8ksgqpkgg545sai7i8hi5a5an394p26b25h1yl9"))
+ "0ybsxpc4339434ha5anix511ckdyp12cym3ld1vsspacxm0h00vi"))
(modules '((guix build utils)))
- (snippet '(begin
- ;; Delete bundled python-prettytable.
- (delete-file-recursively "pyvisa/thirdparty")))))
+ ;; Delete bundled python-prettytable.
+ (snippet '(delete-file-recursively "pyvisa/thirdparty"))))
(build-system pyproject-build-system)
(arguments
- (list #:phases #~(modify-phases %standard-phases
- (add-after 'unpack 'use-system-prettytable
- (lambda _
- (substitute* "pyvisa/shell.py"
- (("from .thirdparty import prettytable")
- "import prettytable")))))))
+ (list
+ #:test-flags
+ '(list "--pyargs" "pyvisa")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'use-system-prettytable
+ (lambda _
+ (substitute* "pyvisa/shell.py"
+ (("from .thirdparty import prettytable")
+ "import prettytable")))))))
(native-inputs
(list python-pytest
python-setuptools
+ python-setuptools-scm
python-wheel))
(propagated-inputs
- (list python-dataclasses
- python-prettytable
+ (list python-prettytable
python-typing-extensions))
(home-page "https://pyvisa.readthedocs.io/en/latest/")
(synopsis "Python binding for the VISA library")